]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/backup-2.nix
Migrate to morph as a replacement to nixops
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
index 3d51fa3bdaf2305fbf0b9bc4d2edde6060d4ec40..d1064c7a5dec513f51f10535ea693307327e530b 100644 (file)
@@ -1,63 +1,75 @@
 { privateFiles }:
-{ config, pkgs, myconfig, resources, ... }:
+{ config, pkgs, resources, name, ... }:
 {
-  boot.kernelPackages = pkgs.linuxPackages_latest;
-  _module.args.privateFiles = privateFiles;
-  _module.args.hostFQDN = "backup-2.v.immae.eu";
-  imports = builtins.attrValues (import ../..);
-
   deployment = {
-    targetEnv = "hetznerCloud";
-    hetznerCloud = {
-      authToken = myconfig.env.hetznerCloud.authToken;
-      datacenter = "hel1-dc2";
-      location  ="hel1";
-      serverType = "cx11";
-    };
+    targetUser = "root";
+    targetHost = config.hostEnv.ips.main.ip4;
+    substituteOnDestination = true;
   };
+  boot.kernelPackages = pkgs.linuxPackages_latest;
+  myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
+
+  imports = [ <nixpkgs/nixos/modules/profiles/qemu-guest.nix> ] ++ builtins.attrValues (import ../..);
 
   fileSystems = {
     "/backup2" = {
       fsType = "ext4";
       device = "UUID=b9425333-f567-435d-94d8-b26c22d93426";
     };
+    "/" = { device = "/dev/sda1"; fsType = "ext4"; };
   };
 
   networking = {
     firewall.enable = true;
     interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
       (n: ips: { address = ips.ip4; prefixLength = 32; })
-      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") myconfig.env.servers.backup-2.ips);
+      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips);
     interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
       (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
-      myconfig.env.servers.backup-2.ips);
+      config.hostEnv.ips);
+    defaultGateway6 = { address = "fe80::1"; interface = "ens3"; };
+  };
 
-    defaultMailServer = {
-      directDelivery = true;
-      hostName = "eldiron.immae.eu:25";
-      useTLS = true;
-      useSTARTTLS = true;
-      root = "postmaster@immae.eu";
-    };
+  boot.loader.grub.device = "nodev";
+
+  myServices.certificates.enable = true;
+  security.acme.certs."${name}" = {
+    user = config.services.nginx.user;
+    group = config.services.nginx.group;
+  };
+  services.nginx = {
+    enable = true;
+    recommendedOptimisation = true;
+    recommendedGzipSettings = true;
+    recommendedProxySettings = true;
+  };
+  networking.firewall.allowedTCPPorts = [ 80 443 ];
+
+  services.cron = {
+    mailto = "cron@immae.eu";
+    enable = true;
   };
 
   services.rsyncBackup = {
     mountpoint = "/backup2";
-    mailto = myconfig.env.rsync_backup.mailto;
-    profiles = myconfig.env.rsync_backup.profiles;
-    ssh_key_public = myconfig.env.rsync_backup.ssh_key.public;
-    ssh_key_private = myconfig.env.rsync_backup.ssh_key.private;
+    profiles = config.myEnv.rsync_backup.profiles;
+    ssh_key_public = config.myEnv.rsync_backup.ssh_key.public;
+    ssh_key_private = config.myEnv.rsync_backup.ssh_key.private;
   };
 
+  myServices.mailRelay.enable = true;
+  myServices.mailBackup.enable = true;
   myServices.monitoring.enable = true;
   myServices.databasesReplication = {
     postgresql = {
       enable = true;
       base = "/backup2";
+      mainPackage = pkgs.postgresql;
       hosts = {
         eldiron = {
           slot = "backup_2";
-          connection = "postgresql://backup-2:${myconfig.env.ldap.backup-2.password}@eldiron.immae.eu";
+          connection = "postgresql://backup-2:${config.hostEnv.ldap.password}@eldiron.immae.eu";
+          package = pkgs.postgresql;
         };
       };
     };
         eldiron = {
           serverId = 2;
           # mysql resolves "backup-2" host and checks the ip, but uses /etc/hosts which only contains ip4
-          host = myconfig.env.servers.eldiron.ips.main.ip4;
+          host = config.myEnv.servers.eldiron.ips.main.ip4;
           port = "3306";
           user = "backup-2";
-          password = myconfig.env.ldap.backup-2.password;
+          password = config.hostEnv.ldap.password;
           dumpUser = "root";
-          dumpPassword = myconfig.env.databases.mysql.systemUsers.root;
+          dumpPassword = config.myEnv.databases.mysql.systemUsers.root;
         };
       };
     };
         };
       };
     };
+    openldap = {
+      enable = true;
+      base = "/backup2";
+      hosts = {
+        eldiron = {
+          url = "ldaps://${config.myEnv.ldap.host}:636";
+          dn = config.myEnv.ldap.replication_dn;
+          password = config.myEnv.ldap.replication_pw;
+          base = config.myEnv.ldap.base;
+        };
+      };
+    };
   };
 
   # This value determines the NixOS release with which your system is
   # database servers. You should change this only after NixOS release
   # notes say you should.
   # https://nixos.org/nixos/manual/release-notes.html
-  system.stateVersion = "19.03"; # Did you read the comment?
+  system.stateVersion = "20.03"; # Did you read the comment?
 }