]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/backup-2.nix
Use attrs for secrets instead of lists
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
index 3d263f570419beb67ea5280762aa57919599dd78..c01a666b7deea692a212ca5cd8ef16fc1c544aea 100644 (file)
@@ -1,26 +1,37 @@
-{ privateFiles }:
 { config, pkgs, resources, name, ... }:
 {
-  boot.kernelPackages = pkgs.linuxPackages_latest;
-  myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
-
-  imports = builtins.attrValues (import ../..);
-
   deployment = {
-    targetEnv = "hetznerCloud";
-    hetznerCloud = {
-      authToken = config.myEnv.hetznerCloud.authToken;
-      datacenter = "hel1-dc2";
-      location  ="hel1";
-      serverType = "cx11";
+    targetUser = "root";
+    targetHost = config.hostEnv.ips.main.ip4;
+    substituteOnDestination = true;
+  };
+  # ssh-keyscan backup-2 | nix-shell -p ssh-to-age --run ssh-to-age
+  secrets.ageKeys = [ "age1kk3nr27qu42j28mcfdag5lhq0zu2pky7gfanvne8l4z2ctevjpgskmw0sr" ];
+  secrets.keys = {
+    "rsync_backup/identity" = {
+      user = "backup";
+      group = "backup";
+      permissions = "0400";
+      text = config.myEnv.rsync_backup.ssh_key.private;
+    };
+    "rsync_backup/identity.pub" = {
+      user = "backup";
+      group = "backup";
+      permissions = "0444";
+      text = config.myEnv.rsync_backup.ssh_key.public;
     };
   };
+  boot.kernelPackages = pkgs.linuxPackages_latest;
+  myEnv = import ../../../nixops/secrets/environment.nix;
+
+  imports = [ <nixpkgs/nixos/modules/profiles/qemu-guest.nix> ] ++ builtins.attrValues (import ../..);
 
   fileSystems = {
     "/backup2" = {
       fsType = "ext4";
       device = "UUID=b9425333-f567-435d-94d8-b26c22d93426";
     };
+    "/" = { device = "/dev/sda1"; fsType = "ext4"; };
   };
 
   networking = {
@@ -34,6 +45,8 @@
     defaultGateway6 = { address = "fe80::1"; interface = "ens3"; };
   };
 
+  boot.loader.grub.device = "nodev";
+
   myServices.certificates.enable = true;
   security.acme.certs."${name}" = {
     user = config.services.nginx.user;
@@ -55,8 +68,8 @@
   services.rsyncBackup = {
     mountpoint = "/backup2";
     profiles = config.myEnv.rsync_backup.profiles;
-    ssh_key_public = config.myEnv.rsync_backup.ssh_key.public;
-    ssh_key_private = config.myEnv.rsync_backup.ssh_key.private;
+    ssh_key_public = config.secrets.fullPaths."rsync_backup/identity.pub";
+    ssh_key_private = config.secrets.fullPaths."rsync_backup/identity";
   };
 
   myServices.mailRelay.enable = true;
     postgresql = {
       enable = true;
       base = "/backup2";
+      mainPackage = pkgs.postgresql;
       hosts = {
         eldiron = {
           slot = "backup_2";
           connection = "postgresql://backup-2:${config.hostEnv.ldap.password}@eldiron.immae.eu";
+          package = pkgs.postgresql;
         };
       };
     };