]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/backup-2.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
index 5d692c65287e42060ab23a84d7cd2ffba32809c1..84e52d59635546e922842ebf0ba957b781e875e6 100644 (file)
@@ -1,15 +1,16 @@
 { privateFiles }:
-{ config, pkgs, myconfig, resources, ... }:
+{ config, pkgs, resources, ... }:
 {
   boot.kernelPackages = pkgs.linuxPackages_latest;
-  _module.args.privateFiles = privateFiles;
-  _module.args.hostFQDN = "backup-2.v.immae.eu";
+  myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
+  hostEnv.FQDN = "backup-2.v.immae.eu";
+
   imports = builtins.attrValues (import ../..);
 
   deployment = {
     targetEnv = "hetznerCloud";
     hetznerCloud = {
-      authToken = myconfig.env.hetznerCloud.authToken;
+      authToken = config.myEnv.hetznerCloud.authToken;
       datacenter = "hel1-dc2";
       location  ="hel1";
       serverType = "cx11";
     firewall.enable = true;
     interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
       (n: ips: { address = ips.ip4; prefixLength = 32; })
-      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") myconfig.env.servers.backup-2.ips);
+      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.myEnv.servers.backup-2.ips);
     interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
       (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
-      myconfig.env.servers.backup-2.ips);
+      config.myEnv.servers.backup-2.ips);
 
     defaultMailServer = {
       directDelivery = true;
 
   services.rsyncBackup = {
     mountpoint = "/backup2";
-    mailto = myconfig.env.rsync_backup.mailto;
-    profiles = myconfig.env.rsync_backup.profiles;
-    ssh_key_public = myconfig.env.rsync_backup.ssh_key.public;
-    ssh_key_private = myconfig.env.rsync_backup.ssh_key.private;
+    mailto = config.myEnv.rsync_backup.mailto;
+    profiles = config.myEnv.rsync_backup.profiles;
+    ssh_key_public = config.myEnv.rsync_backup.ssh_key.public;
+    ssh_key_private = config.myEnv.rsync_backup.ssh_key.private;
   };
 
   myServices.monitoring.enable = true;
@@ -62,7 +63,7 @@
       hosts = {
         eldiron = {
           slot = "backup_2";
-          connection = "postgresql://backup-2:${myconfig.env.ldap.backup-2.password}@eldiron.immae.eu";
+          connection = "postgresql://backup-2:${config.myEnv.servers.backup-2.ldap.password}@eldiron.immae.eu";
         };
       };
     };
         eldiron = {
           serverId = 2;
           # mysql resolves "backup-2" host and checks the ip, but uses /etc/hosts which only contains ip4
-          host = myconfig.env.servers.eldiron.ips.main.ip4;
+          host = config.myEnv.servers.eldiron.ips.main.ip4;
           port = "3306";
           user = "backup-2";
-          password = myconfig.env.ldap.backup-2.password;
+          password = config.myEnv.servers.backup-2.ldap.password;
           dumpUser = "root";
-          dumpPassword = myconfig.env.databases.mysql.systemUsers.root;
+          dumpPassword = config.myEnv.databases.mysql.systemUsers.root;
         };
       };
     };
       base = "/backup2";
       hosts = {
         eldiron = {
-          url = "ldaps://${myconfig.env.ldap.host}:636";
-          dn = myconfig.env.ldap.replication_dn;
-          password = myconfig.env.ldap.replication_pw;
-          base = myconfig.env.ldap.base;
+          url = "ldaps://${config.myEnv.ldap.host}:636";
+          dn = config.myEnv.ldap.replication_dn;
+          password = config.myEnv.ldap.replication_pw;
+          base = config.myEnv.ldap.base;
         };
       };
     };