]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/backup-2.nix
Add disk to backup-2
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
index c67eab64a609b928bd754a819a81e57f4d549436..80fa36df1253fa883eca1e1371a34720a41c8587 100644 (file)
@@ -1,5 +1,5 @@
 { privateFiles }:
-{ config, pkgs, myconfig, ... }:
+{ config, pkgs, myconfig, resources, ... }:
 {
   boot.kernelPackages = pkgs.linuxPackages_latest;
   _module.args.privateFiles = privateFiles;
     };
   };
 
+  fileSystems = {
+    "/backup2" = {
+      fsType = "ext4";
+      device = "UUID=b9425333-f567-435d-94d8-b26c22d93426";
+    };
+  };
+
+  networking = {
+    firewall.enable = true;
+    interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
+      (n: ips: { address = ips.ip4; prefixLength = 32; })
+      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") myconfig.env.servers.backup-2.ips);
+    interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
+      (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
+      myconfig.env.servers.backup-2.ips);
+  };
+
   # This value determines the NixOS release with which your system is
   # to be compatible, in order to avoid breaking some software such as
   # database servers. You should change this only after NixOS release