]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/backup-2.nix
Remove mail command in backup script
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
index 1c5b7d84b383cebbd86a839c3872d5f1dd670d7c..4e24c1244253009ea0b844b319542cde52f0cbb1 100644 (file)
@@ -1,14 +1,15 @@
 { privateFiles }:
-{ config, pkgs, myconfig, resources, ... }:
+{ config, pkgs, resources, ... }:
 {
   boot.kernelPackages = pkgs.linuxPackages_latest;
-  _module.args.privateFiles = privateFiles;
+  myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
+
   imports = builtins.attrValues (import ../..);
 
   deployment = {
     targetEnv = "hetznerCloud";
     hetznerCloud = {
-      authToken = myconfig.env.hetznerCloud.authToken;
+      authToken = config.myEnv.hetznerCloud.authToken;
       datacenter = "hel1-dc2";
       location  ="hel1";
       serverType = "cx11";
     firewall.enable = true;
     interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
       (n: ips: { address = ips.ip4; prefixLength = 32; })
-      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") myconfig.env.servers.backup-2.ips);
+      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips);
     interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
       (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
-      myconfig.env.servers.backup-2.ips);
+      config.hostEnv.ips);
+    defaultGateway6 = { address = "fe80::1"; interface = "ens3"; };
+  };
 
-    defaultMailServer = {
-      directDelivery = true;
-      hostName = "eldiron.immae.eu:25";
-      useTLS = true;
-      useSTARTTLS = true;
-      root = "postmaster@immae.eu";
-    };
+  myServices.certificates.enable = true;
+  services.nginx = {
+    enable = true;
+    recommendedOptimisation = true;
+    recommendedGzipSettings = true;
+    recommendedProxySettings = true;
+  };
+  networking.firewall.allowedTCPPorts = [ 80 443 ];
+
+  services.cron = {
+    mailto = "cron@immae.eu";
+    enable = true;
   };
 
   services.rsyncBackup = {
     mountpoint = "/backup2";
-    mailto = myconfig.env.rsync_backup.mailto;
-    profiles = myconfig.env.rsync_backup.profiles;
-    ssh_key_public = myconfig.env.rsync_backup.ssh_key.public;
-    ssh_key_private = myconfig.env.rsync_backup.ssh_key.private;
+    profiles = config.myEnv.rsync_backup.profiles;
+    ssh_key_public = config.myEnv.rsync_backup.ssh_key.public;
+    ssh_key_private = config.myEnv.rsync_backup.ssh_key.private;
   };
 
+  myServices.mailRelay.enable = true;
+  myServices.mailBackup.enable = true;
+  myServices.monitoring.enable = true;
   myServices.databasesReplication = {
     postgresql = {
       enable = true;
       hosts = {
         eldiron = {
           slot = "backup_2";
-          connection = "postgresql://backup-2:${myconfig.env.ldap.backup-2.password}@eldiron.immae.eu";
+          connection = "postgresql://backup-2:${config.hostEnv.ldap.password}@eldiron.immae.eu";
+        };
+      };
+    };
+    mariadb = {
+      enable = true;
+      base = "/backup2";
+      hosts = {
+        eldiron = {
+          serverId = 2;
+          # mysql resolves "backup-2" host and checks the ip, but uses /etc/hosts which only contains ip4
+          host = config.myEnv.servers.eldiron.ips.main.ip4;
+          port = "3306";
+          user = "backup-2";
+          password = config.hostEnv.ldap.password;
+          dumpUser = "root";
+          dumpPassword = config.myEnv.databases.mysql.systemUsers.root;
+        };
+      };
+    };
+    redis = {
+      enable = true;
+      base = "/backup2";
+      hosts = {
+        eldiron = {
+          host = "127.0.0.1";
+          port = "16379";
+        };
+      };
+    };
+    openldap = {
+      enable = true;
+      base = "/backup2";
+      hosts = {
+        eldiron = {
+          url = "ldaps://${config.myEnv.ldap.host}:636";
+          dn = config.myEnv.ldap.replication_dn;
+          password = config.myEnv.ldap.replication_pw;
+          base = config.myEnv.ldap.base;
         };
       };
     };