]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/ssh/default.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / ssh / default.nix
index d4c1ab3ffac3b8c462b4ca5139d40c8c351555dc..1699104a370f914a8885374dfff39983b3a1a4a4 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig, ... }:
+{ lib, pkgs, config, ... }:
 let
   cfg = config.myServices.ssh;
 in
@@ -56,7 +56,7 @@ in
       user = "nobody";
       group = "nogroup";
       permissions = "0400";
-      text = myconfig.env.sshd.ldap.password;
+      text = config.myEnv.sshd.ldap.password;
     }];
     system.activationScripts.sshd = {
       deps = [ "secrets" ];