]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/ssh/default.nix
Use attrs for secrets instead of lists
[perso/Immae/Config/Nix.git] / modules / private / ssh / default.nix
index ca9b6fc34d525fb3258788a107c60c729cb9ed3a..ee5dda5c4eb32072ca03ca1df421dd918c223777 100644 (file)
@@ -51,13 +51,12 @@ in
       AuthorizedKeysCommandUser nobody
       '';
 
-    secrets.keys = [{
-      dest = "ssh-ldap";
+    secrets.keys."ssh-ldap" = {
       user = "nobody";
       group = "nogroup";
       permissions = "0400";
       text = config.myEnv.sshd.ldap.password;
-    }];
+    };
     system.activationScripts.sshd = {
       deps = [ "secrets" ];
       text = ''