]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/pub/default.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / pub / default.nix
index 835bcec9a094279fd67ceb7bed513df0cef397ec..790395c68f9b3b7b9dc5be9217c99fe729426a34 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 {
   options = {
     myServices.pub.enable = lib.mkOption {
@@ -43,7 +43,7 @@
       createHome = true;
       description = "Restricted shell user";
       home = "/var/lib/pub";
-      uid = myconfig.env.users.pub.uid;
+      uid = config.myEnv.users.pub.uid;
       useDefaultShell = true;
       packages = [
         restrict