]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/pub/default.nix
Add more profiles for ovh
[perso/Immae/Config/Nix.git] / modules / private / pub / default.nix
index 835bcec9a094279fd67ceb7bed513df0cef397ec..18c146baeca7ac80afbc12a2ba14499892276109 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 {
   options = {
     myServices.pub.enable = lib.mkOption {
     }];
     services.duplyBackup.profiles.pub = {
       rootDir = "/var/lib/pub";
+      remotes = [ "eriomem" "ovh" ];
     };
     users.users.pub = let
-      restrict = pkgs.runCommand "restrict" { 
+      restrict = pkgs.runCommand "restrict" {
         file = ./restrict;
         buildInputs = [ pkgs.makeWrapper ];
       } ''
@@ -43,7 +44,7 @@
       createHome = true;
       description = "Restricted shell user";
       home = "/var/lib/pub";
-      uid = myconfig.env.users.pub.uid;
+      uid = config.myEnv.users.pub.uid;
       useDefaultShell = true;
       packages = [
         restrict