]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/pub/default.nix
Move rest of the modules outside of nixops
[perso/Immae/Config/Nix.git] / modules / private / pub / default.nix
similarity index 93%
rename from nixops/modules/pub/default.nix
rename to modules/private/pub/default.nix
index cdc68db2f8b6156e7b1448ed95b1d00eeeb45174..c31c8eb0e40e8367838e270b1d6848562820c6c8 100644 (file)
@@ -1,7 +1,7 @@
 { lib, pkgs, config, myconfig,  ... }:
 {
   options = {
-    services.pub.enable = lib.mkOption {
+    myServices.pub.enable = lib.mkOption {
       type = lib.types.bool;
       default = false;
       description = ''
@@ -10,7 +10,7 @@
     };
   };
 
-  config = lib.mkIf config.services.pub.enable {
+  config = lib.mkIf config.myServices.pub.enable {
     users.users.pub = let
       restrict = pkgs.runCommand "restrict" { 
         file = ./restrict;