]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/mpd.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / mpd.nix
index c7e24862e00ad4c038187867e8aba9fb67ba6a9f..1e6e666d978f6881a70f92f3aca66d04030e831e 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 {
   options.myServices.mpd.enable = lib.mkEnableOption "enable MPD";
   config = lib.mkIf config.myServices.mpd.enable {
@@ -9,7 +9,7 @@
       {
         dest = "mpd";
         permissions = "0400";
-        text = myconfig.env.mpd.password;
+        text = config.myEnv.mpd.password;
       }
       {
         dest = "mpd-config";
@@ -17,7 +17,7 @@
         user = "mpd";
         group = "mpd";
         text = ''
-          password "${myconfig.env.mpd.password}@read,add,control,admin"
+          password "${config.myEnv.mpd.password}@read,add,control,admin"
         '';
       }
     ];
@@ -32,7 +32,7 @@
     services.mpd = {
       enable = true;
       network.listenAddress = "any";
-      musicDirectory = myconfig.env.mpd.folder;
+      musicDirectory = config.myEnv.mpd.folder;
       extraConfig = ''
         include "/var/secrets/mpd-config"
         audio_output {