]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_tiboqorl-fr.nix
Add config for CI
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_tiboqorl-fr.nix
index 97b7f7b8ba8598d0a5ae9508819a76c52fc48313..b49a1d8e31651155706d25c9ae9a138ac898008a 100644 (file)
@@ -7,8 +7,10 @@ let
     use = "external-passive-service";
     contact_groups = "tiboqorl";
     freshness_threshold = "450";
+    notification_interval = "240";
     retry_interval = "1";
     servicegroups = "webstatus-resources";
+    _webstatus_namespace = "tiboqorl";
     host_name = hostFQDN;
   };
 in
@@ -21,6 +23,8 @@ in
       contact_groups = "tiboqorl";
       hostgroups = "webstatus-hosts";
       _webstatus_name = "tiboqorl";
+      _webstatus_vhost = "status.immae.eu";
+      _webstatus_namespace = "tiboqorl";
     };
   };
   service = [
@@ -56,8 +60,8 @@ in
       use = "local-service";
       check_command = [
         "check_local_load"
-        "3.0,3.0,3.0" # warn
-        "4.0,4.0,4.0" # alert
+        "0.75,0.75,0.75" # warn
+        "1.0,1.0,1.0" # alert
       ];
     }
     {
@@ -81,10 +85,10 @@ in
   ];
   command = {
     check_local_disk = "$USER1$/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$";
-    check_local_procs = "/usr/bin/sudo $USER1$/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$";
+    check_local_procs = "$USER1$/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$";
     check_local_load = "$USER1$/check_load -w $ARG1$ -c $ARG2$";
     check_local_swap = "$USER1$/check_swap -n ok -w $ARG1$ -c $ARG2$";
-    check_local_bandwidth = "/usr/bin/sudo $USER2$/check_bandwidth -i=$ARG1$ -w $ARG2$ -c $ARG3$";
+    check_local_bandwidth = "$USER2$/check_bandwidth -i=$ARG1$ -w $ARG2$ -c $ARG3$";
     check_memory = "$USER2$/check_mem.sh -w $ARG1$ -c $ARG2$";
     check_ntp = "$USER1$/check_ntp_time -t 30 -q -H 0.arch.pool.ntp.org";