]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_phare.nix
Refactor monitoring to avoid useless resources in each machine
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_phare.nix
index ab4643683027b266a5b7148ae62df6ee731572a1..082e7e30a09a6d14cf40c915f3a04bdc32c3c319 100644 (file)
@@ -1,5 +1,6 @@
-{ ... }:
+{ emailCheck, ... }:
 {
+  activatedPlugins = [ "emails" ];
   host = {
     "phare.normalesup.org" = {
       alias = "phare.normalesup.org";
@@ -7,16 +8,10 @@
       use = "linux-server";
       hostgroups = "webstatus-hosts";
       _webstatus_name = "phare";
+      _webstatus_vhost = "status.immae.eu";
     };
   };
   service = [
-    {
-      service_description = "phare.normalesup.org email service is active";
-      use = "external-passive-service";
-      host_name = "phare.normalesup.org";
-      freshness_threshold = "1350";
-      retry_interval = "1";
-      servicegroups = "webstatus-email";
-    }
+    (emailCheck "phare" "phare.normalesup.org")
   ];
 }