]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_monitoring-1.nix
Disable duply backups
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_monitoring-1.nix
index 741860afee21640d499b87f182d095455dbedff1..94b676bd701cc09bb5517060446c5b8be2898204 100644 (file)
@@ -1,4 +1,26 @@
-{ config, pkgs, hostFQDN, emailCheck, ... }:
+{ config, pkgs, nodes, hostFQDN, emailCheck, lib, ... }:
+let
+  to_resource = func: cfg: lib.flatten (lib.optionals cfg.enable (lib.mapAttrsToList func cfg.profiles));
+  to_backup_age_dependency = name: profile: map (remote:
+    {
+      dependent_host_name = "eldiron.immae.eu";
+      host_name           = "eldiron.immae.eu";
+      dependent_service_description = "${remote} backup for ${name} is not too old";
+      service_description = "${remote} backup is up and not full";
+      execution_failure_criteria = "u";
+      notification_failure_criteria = "u";
+    }) profile.remotes;
+  to_backup_age = name: profile: map (remote:
+    {
+      service_description = "${remote} backup for ${name} is not too old";
+      host_name = "eldiron.immae.eu";
+      use = "external-service";
+      check_command = ["check_backup_${remote}_age" name];
+
+      check_interval = "120";
+      notification_interval = "1440";
+    }) profile.remotes;
+in
 {
   host = {
     # Dummy host for testing
       check_command = "check_ovh_sms";
 
       check_interval = "120";
-      notification_interval = "120";
+      notification_interval = "1440";
     }
 
     # Backup services
     {
-      service_description = "Eriomem backup is up and not full";
+      service_description = "eriomem backup is up and not full";
+      host_name = "eldiron.immae.eu";
+      use = "external-service";
+      check_command = "check_backup_eriomem";
+
+      check_interval = "120";
+      notification_interval = "1440";
+
+      servicegroups = "webstatus-backup";
+    }
+    {
+      service_description = "ovh backup is up and not full";
       host_name = "eldiron.immae.eu";
       use = "external-service";
-      check_command = "check_eriomem";
+      check_command = "check_ok";
 
       check_interval = "120";
-      notification_interval = "120";
+      notification_interval = "1440";
 
       servicegroups = "webstatus-backup";
     }
       service_description = "roundcube website is running on mail.immae.eu";
       host_name = "eldiron.immae.eu";
       use = "external-web-service";
-      check_command = ["check_https_code" "mail.immae.eu" "/roundcube/" "401" "<title>Roundcube"];
+      check_command = ["check_https" "mail.immae.eu" "/roundcube/" "<title>Roundcube"];
 
       servicegroups = "webstatus-webapps,webstatus-email";
       _webstatus_name = "Roundcube";
       _webstatus_url = "https://www.sandetludo.com/";
     }
 
-    {
-      service_description = "Maison bbc accepts add requests on http";
-      host_name = "eldiron.immae.eu";
-      use = "external-web-service";
-      check_command = [ "check_http" "maison.bbc.bouya.org" "/add.php" "^$"];
-    }
-
-    {
-      service_description = "Maison bbc has up to date data";
-      host_name = "eldiron.immae.eu";
-      use = "generic-service";
-      contact_groups = "maison-bbc";
-      notification_interval = "1440";
-      check_command = "check_maison_bbc";
-      flap_detection_enabled = "0";
-      max_check_attempts = "1";
-    }
-
     # SSL
     {
       service_description = "ldap SSL is up to date";
       _webstatus_name = "LDAP";
       _webstatus_url = "ldap.immae.eu";
     }
-  ];
+
+    # Tiboqorl
+    {
+      service_description = "Cyllene support page is running";
+      host_name = "tiboqorl.fr";
+      use = "external-web-service";
+      contact_groups = "tiboqorl";
+      check_command = [ "check_https" "sc.groupe-cyllene.com" "/" "<title>Support Client Cyllene" ];
+    }
+  ] ++ to_resource to_backup_age nodes.eldiron.config.services.duplyBackup;
   contact = {
     telio-tortay = config.myEnv.monitoring.contacts.telio-tortay // {
       use = "generic-contact";
       contactgroups = "telio-tortay";
     };
-    papa = config.myEnv.monitoring.contacts.papa // {
+    thibault = config.myEnv.monitoring.contacts.thibault // {
       use = "generic-contact";
-      contactgroups = "maison-bbc";
-      service_notification_commands = "notify-maison-bbc-by-email";
+      contactgroups = "tiboqorl";
     };
   };
   contactgroup = {
-    maison-bbc = { alias = "Maison BBC"; };
     telio-tortay = { alias = "Telio Tortay"; members = "immae"; };
+    tiboqorl = { alias = "Tiboqorl"; members = "immae"; };
   };
+  servicedependency = to_resource to_backup_age_dependency nodes.eldiron.config.services.duplyBackup;
 }