]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_monitoring-1.nix
Upgrade roundcube
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_monitoring-1.nix
index a46b684ebc3c25a1a406fd5a87b587bcffdece75..46916f41edd28930adcfb975c2ec7ab656bb1355 100644 (file)
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, hostFQDN, emailCheck, ... }:
 {
   host = {
     # Dummy host for testing
@@ -22,6 +22,8 @@
     #   check_command = "check_critical";
     # }
 
+    (emailCheck "monitoring-1" hostFQDN)
+
     {
       service_description = "ftp has access to database for authentication";
       host_name = "eldiron.immae.eu";
       _webstatus_url = "imap.immae.eu";
     }
 
+    # Third party services
+    {
+      service_description = "OVH account has enough sms";
+      host_name = "eldiron.immae.eu";
+      use = "external-service";
+      check_command = "check_ovh_sms";
+
+      check_interval = "120";
+      notification_interval = "120";
+    }
+
+    # Backup services
+    {
+      service_description = "Eriomem backup is up and not full";
+      host_name = "eldiron.immae.eu";
+      use = "external-service";
+      check_command = "check_eriomem";
+
+      check_interval = "120";
+      notification_interval = "120";
+
+      servicegroups = "webstatus-backup";
+    }
+
     # DNS services
     {
       service_description = "eldiron dns is active and authoritative for aten.pro";
       service_description = "roundcube website is running on mail.immae.eu";
       host_name = "eldiron.immae.eu";
       use = "external-web-service";
-      check_command = ["check_https_code" "mail.immae.eu" "/roundcube/" "401" "<title>Roundcube"];
+      check_command = ["check_https" "mail.immae.eu" "/roundcube/" "<title>Roundcube"];
 
       servicegroups = "webstatus-webapps,webstatus-email";
       _webstatus_name = "Roundcube";
       service_description = "Telio website is running on realistesmedia.fr";
       host_name = "eldiron.immae.eu";
       use = "external-web-service";
-      check_command = ["check_https" "realistesmedia.fr" "/" "<title>RĂ©al'istes"];
+      check_command = ["check_https" "realistesmedia.fr" "/" "doctype html"];
       contact_groups = "telio-tortay";
     }