]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_monitoring-1.nix
Add sms check to monitoring
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_monitoring-1.nix
index f69d3ffb37268c8039b17e155d3859e13eb74009..10327b8a686430c31a6e094534ab5e7a6a9f50ae 100644 (file)
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, hostFQDN, emailCheck, ... }:
 {
   host = {
     # Dummy host for testing
@@ -22,6 +22,8 @@
     #   check_command = "check_critical";
     # }
 
+    (emailCheck "monitoring-1" hostFQDN)
+
     {
       service_description = "ftp has access to database for authentication";
       host_name = "eldiron.immae.eu";
       _webstatus_url = "imap.immae.eu";
     }
 
+    # Third party services
+    {
+      service_description = "OVH account has enough sms";
+      host_name = "eldiron.immae.eu";
+      use = "external-service";
+      check_command = "check_ovh_sms";
+
+      check_interval = "120";
+      notification_interval = "120";
+    }
+
     # Backup services
     {
       service_description = "Eriomem backup is up and not full";