]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_eban.nix
Add config for CI
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_eban.nix
index 659b0ec5eca7c0730e2f9e7b1ef74cec72cdedae..df54f6a5223f8caf3183cee46b60ece1b5d19ad9 100644 (file)
@@ -8,9 +8,11 @@ let
     check_interval = "15";
 
     servicegroups = "webstatus-resources";
+    _webstatus_namespace = "eban";
   } // rest;
 in
 {
+  activatedPlugins = [ "http" ];
   contact = {
     eban = {
       use = "generic-contact";
@@ -28,6 +30,7 @@ in
       contact_groups = "null";
       _webstatus_name = "Eban";
       _webstatus_vhost = "status.eban.bzh";
+      _webstatus_namespace = "eban";
     };
   };
   service = [
@@ -50,11 +53,18 @@ in
       _webstatus_url = "https://git.eban.bzh/";
     })
     (serviceTemplate {
-      service_description = "Eban Cloud is up and running";
-      check_command = ["check_https" "cloud.eban.bzh" "/" "<title>"];
+      service_description = "I Learned website is up and running";
+      check_command = [ "check_https" "ilearned.eu.org" "/" "<title" ];
 
-      _webstatus_name = "Cloud";
-      _webstatus_url = "https://cloud.eban.bzh/";
+      _webstatus_name = "I Learned website";
+      _webstatus_url = "https://ilearned.eu.org/";
+    })
+    (serviceTemplate {
+      service_description = "I Learned gitea is up and running";
+      check_command = [ "check_https" "git.ilearned.eu.org" "/" "<title" ];
+
+      _webstatus_name = "I Learned Git";
+      _webstatus_url = "https://git.ilearned.eu.org/";
     })
   ];
 }