]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_eban.nix
Add monitoring for Eban
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_eban.nix
index 9ad49e1402f66a66e7c22f8dd0cea08d6ae450fa..1e831d571fe497895abb8af1c387473257a01c34 100644 (file)
@@ -12,6 +12,7 @@ let
   } // rest;
 in
 {
+  activatedPlugins = [ "http" ];
   contact = {
     eban = {
       use = "generic-contact";
@@ -58,5 +59,19 @@ in
       _webstatus_name = "Bitwarden";
       _webstatus_url = "https://bitwarden.eban.bzh/";
     })
+    (serviceTemplate {
+      service_description = "I Learned website is up and running";
+      check_command = [ "check_https" "ilearned.eu.org" "/" "<title" ];
+
+      _webstatus_name = "I Learned website";
+      _webstatus_url = "https://ilearned.eu.org/";
+    })
+    (serviceTemplate {
+      service_description = "I Learned gitea is up and running";
+      check_command = [ "check_https" "git.ilearned.eu.org" "/" "<title" ];
+
+      _webstatus_name = "I Learned Git";
+      _webstatus_url = "https://git.ilearned.eu.org/";
+    })
   ];
 }