]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_eban.nix
Refactor monitoring to avoid useless resources in each machine
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_eban.nix
index 659b0ec5eca7c0730e2f9e7b1ef74cec72cdedae..15b19b9d7adaffa159931fb662166c3be35dec7f 100644 (file)
@@ -8,9 +8,11 @@ let
     check_interval = "15";
 
     servicegroups = "webstatus-resources";
+    _webstatus_namespace = "eban";
   } // rest;
 in
 {
+  activatedPlugins = [ "http" ];
   contact = {
     eban = {
       use = "generic-contact";
@@ -28,6 +30,7 @@ in
       contact_groups = "null";
       _webstatus_name = "Eban";
       _webstatus_vhost = "status.eban.bzh";
+      _webstatus_namespace = "eban";
     };
   };
   service = [
@@ -50,11 +53,11 @@ in
       _webstatus_url = "https://git.eban.bzh/";
     })
     (serviceTemplate {
-      service_description = "Eban Cloud is up and running";
-      check_command = ["check_https" "cloud.eban.bzh" "/" "<title>"];
+      service_description = "Eban Bitwarden is up and running";
+      check_command = ["check_https" "bitwarden.eban.bzh" "/" "<title"];
 
-      _webstatus_name = "Cloud";
-      _webstatus_url = "https://cloud.eban.bzh/";
+      _webstatus_name = "Bitwarden";
+      _webstatus_url = "https://bitwarden.eban.bzh/";
     })
   ];
 }