]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/default.nix
Add some monitoring services (eriomem)
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
index 2c2f693a9a0fd64dff62ba53cca937dd1b9d92b8..e1357a75544a73ebc8c55e56f46b32b63af1bd3a 100644 (file)
@@ -38,6 +38,9 @@ let
     wrapProgram $out/check_imap_connection --prefix PATH : ${lib.makeBinPath [
       pkgs.openssl
     ]}
+    wrapProgram $out/check_eriomem --prefix PATH : ${lib.makeBinPath [
+      pkgs.s3cmd pkgs.python3
+    ]}
     wrapProgram $out/notify_maison_bbc_by_email --prefix PATH : ${lib.makeBinPath [
       pkgs.mailutils pkgs.gawk
     ]}
@@ -55,7 +58,7 @@ let
       loadWarn = "8.0"; loadAlert = "10.0";
     };
     backup-2 = {
-      processWarn = "50"; processAlert = "60";
+      processWarn = "60"; processAlert = "70";
       loadWarn = "1.0"; loadAlert = "2.0";
     };
     monitoring-1 = {
@@ -220,6 +223,7 @@ in
         $USER205$=${config.myEnv.monitoring.imap_password}
         $USER206$=${config.myEnv.monitoring.slack_channel}
         $USER207$=${config.myEnv.monitoring.slack_url}
+        $USER208$=${builtins.concatStringsSep "," (map (builtins.concatStringsSep ":") config.myEnv.monitoring.eriomem_keys)}
       '';
       objectDefs = toObjects commonObjects
         + toObjects hostObjects