]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/default.nix
Add mysql and redis monitoring
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
index 6062abab2e1689e5c02eb57983ad84f0c49e5273..b3f8cbee734cf53f3c672e88171a2f036282fc4d 100644 (file)
@@ -16,43 +16,33 @@ let
     wrapProgram $out/check_postgres_replication --prefix PATH : ${lib.makeBinPath [
       pkgs.postgresql
     ]}
+    wrapProgram $out/check_redis_replication --prefix PATH : ${lib.makeBinPath [
+      pkgs.gnugrep pkgs.coreutils pkgs.redis
+    ]}
+    wrapProgram $out/check_mysql_replication --prefix PATH : ${lib.makeBinPath [
+      pkgs.gnugrep pkgs.gnused pkgs.coreutils pkgs.mariadb
+    ]}
     '';
-  defaultObjects =
-    let specific_file = ./conf + "/specific_" + name + ".cfg";
+  toObjects = pkgs.callPackage ./to_objects.nix {};
+  commonConfig = {
+    eldiron = {
+      processWarn = "250"; processAlert = "400";
+      loadWarn = "8.0"; loadAlert = "10.0";
+    };
+    backup-2 = {
+      processWarn = "50"; processAlert = "60";
+      loadWarn = "1.0"; loadAlert = "2.0";
+    };
+  };
+  commonObjects = pkgs.callPackage ./objects_common.nix ({
+    inherit hostFQDN;
+    sudo = "/run/wrappers/bin/sudo";
+  } // builtins.getAttr name commonConfig);
+  hostObjects =
+    let
+      specific_file = ./. + "/objects_" + name + ".nix";
     in
-        builtins.readFile ./conf/local_services.cfg
-      + builtins.readFile ./conf/timeperiods.cfg
-      + builtins.readFile ./conf/services.cfg
-      + builtins.readFile ./conf/contacts.cfg
-      + builtins.readFile ./conf/hosts.cfg
-      + ''
-        define command {
-          command_line       ${myplugins}/send_nrdp.sh -u "$USER200$" -t "$USER201$" -H "$HOSTADDRESS$" -s "$SERVICEDESC$" -S "$SERVICESTATEID$" -o "$SERVICEOUTPUT$"
-          command_name       notify-master
-        }
-        define service {
-          service_description  No mdadm array is degraded
-          use                  local-service
-          check_command        check_command_output!${pkgs.mdadm}/bin/mdadm --monitor --scan -1!^$!-s 0 -r root
-        }
-
-        define service {
-          name                local-service
-          use                 generic-service
-          host_name           ${hostFQDN}
-          check_interval      5
-          max_check_attempts  4
-          register            0
-          retry_interval      1
-        }
-        define host {
-          host_name           ${hostFQDN}
-          alias               ${hostFQDN}
-          address             ${hostFQDN}
-          use                 linux-server
-        }
-        ''
-      + lib.strings.optionalString (builtins.pathExists specific_file) (builtins.readFile specific_file);
+      lib.attrsets.optionalAttrs (builtins.pathExists specific_file) (pkgs.callPackage specific_file {});
 in
 {
   options = {
@@ -88,6 +78,22 @@ in
         users = [ "naemon" ];
         runAs = "postgres";
       }
+      {
+        commands = [
+          { command = "${myplugins}/check_mysql_replication *"; options = [ "NOPASSWD" ]; }
+          { command = "${myplugins}/check_last_file_date /backup2/*"; options = [ "NOPASSWD" ]; }
+        ];
+        users = [ "naemon" ];
+        runAs = "mysql";
+      }
+      {
+        commands = [
+          { command = "${myplugins}/check_redis_replication *"; options = [ "NOPASSWD" ]; }
+          { command = "${myplugins}/check_last_file_date /backup2/*"; options = [ "NOPASSWD" ]; }
+        ];
+        users = [ "naemon" ];
+        runAs = "redis";
+      }
       {
         commands = [
           { command = "${myplugins}/check_last_file_date /backup2/*"; options = [ "NOPASSWD" ]; }
@@ -122,7 +128,7 @@ in
         $USER200$=${myconfig.env.monitoring.status_url}
         $USER201$=${myconfig.env.monitoring.status_token}
       '';
-      objectDefs = defaultObjects;
+      objectDefs = toObjects commonObjects + toObjects hostObjects;
     };
   };
 }