]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/default.nix
Add status engine website
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
index e44b127488e3691090721c9d856dbde2534af985..8ae0b306fe1b951a48b13162f55670e27780382b 100644 (file)
@@ -1,5 +1,21 @@
-{ config, myconfig, pkgs, lib, name, hostFQDN, ... }:
+{ config, pkgs, lib, name, nodes, ... }:
 let
+  cfg = config.myServices.monitoring;
+  send_mails = pkgs.runCommand "send_mails" {
+    buildInputs = [ pkgs.makeWrapper ];
+  } ''
+    mkdir -p $out/bin
+    cp ${./send_mails} $out/bin/send_mails
+    patchShebangs $out
+    wrapProgram $out/bin/send_mails --prefix PATH : ${lib.makeBinPath [
+      pkgs.mailutils
+    ]}
+    '';
+  postgresqlBinary = if config.myServices.databasesReplication.postgresql.enable
+    then config.myServices.databasesReplication.postgresql.mainPackage
+    else if config.myServices.databases.enable
+    then config.myServices.databases.postgresql.package
+    else pkgs.postgresql;
   myplugins = pkgs.runCommand "buildplugins" {
     buildInputs = [ pkgs.makeWrapper pkgs.perl ];
   } ''
@@ -14,7 +30,7 @@ let
       pkgs.gnugrep pkgs.gawk pkgs.procps-ng
     ]}
     wrapProgram $out/check_postgres_replication --prefix PATH : ${lib.makeBinPath [
-      pkgs.postgresql
+      postgresqlBinary
     ]}
     wrapProgram $out/check_redis_replication --prefix PATH : ${lib.makeBinPath [
       pkgs.gnugrep pkgs.coreutils pkgs.redis
@@ -25,6 +41,32 @@ let
     wrapProgram $out/check_openldap_replication --prefix PATH : ${lib.makeBinPath [
       pkgs.gnugrep pkgs.gnused pkgs.coreutils pkgs.openldap
     ]}
+    wrapProgram $out/check_emails --prefix PATH : ${lib.makeBinPath [
+      pkgs.openssh send_mails
+    ]} --prefix PERL5LIB : ${pkgs.perlPackages.makePerlPath [
+      pkgs.perlPackages.TimeDate
+    ]}
+    wrapProgram $out/check_ftp_database --prefix PATH : ${lib.makeBinPath [
+      pkgs.lftp
+    ]}
+    wrapProgram $out/check_git --prefix PATH : ${lib.makeBinPath [
+      pkgs.git pkgs.openssh
+    ]}
+    wrapProgram $out/check_imap_connection --prefix PATH : ${lib.makeBinPath [
+      pkgs.openssl
+    ]}
+    wrapProgram $out/check_eriomem --prefix PATH : ${lib.makeBinPath [
+      pkgs.s3cmd pkgs.python3
+    ]}
+    wrapProgram $out/notify_by_email --prefix PATH : ${lib.makeBinPath [
+      pkgs.mailutils
+    ]}
+    wrapProgram $out/notify_by_slack --prefix PATH : ${lib.makeBinPath [
+      pkgs.curl pkgs.jq
+    ]}
+    wrapProgram $out/check_ovh_sms --prefix PATH : ${lib.makeBinPath [
+      (pkgs.python3.withPackages (ps: [ps.ovh]))
+    ]}
     '';
   toObjects = pkgs.callPackage ./to_objects.nix {};
   commonConfig = {
@@ -33,19 +75,71 @@ let
       loadWarn = "8.0"; loadAlert = "10.0";
     };
     backup-2 = {
+      processWarn = "60"; processAlert = "70";
+      loadWarn = "1.0"; loadAlert = "2.0";
+    };
+    monitoring-1 = {
       processWarn = "50"; processAlert = "60";
       loadWarn = "1.0"; loadAlert = "2.0";
     };
   };
+  masterPassiveObjects = let
+    passiveNodes = lib.attrsets.filterAttrs (n: _: builtins.elem n ["backup-2" "eldiron"]) nodes;
+    toPassiveServices = map (s: s.passiveInfo.filter s // s.passiveInfo);
+    passiveServices = lib.flatten (lib.attrsets.mapAttrsToList
+      (_: n: toPassiveServices n.config.myServices.monitoring.services)
+      passiveNodes
+      );
+  in {
+    service = passiveServices;
+    host = lib.lists.foldr
+      (a: b: a//b)
+      {}
+      (lib.attrsets.mapAttrsToList (_: h: h.config.myServices.monitoring.hosts) passiveNodes);
+  };
+  emailCheck = host: hostFQDN: let
+    allCfg = config.myEnv.monitoring.email_check;
+    cfg = allCfg."${host}";
+    reverseTargets = builtins.attrNames (lib.attrsets.filterAttrs (k: v: builtins.elem host v.targets) allCfg);
+    to_email = cfg': host':
+      let sep = if lib.strings.hasInfix "+" cfg'.mail_address then "_" else "+";
+      in "${cfg'.mail_address}${sep}${host'}@${cfg'.mail_domain}";
+    mails_to_send = builtins.concatStringsSep "," (map (n: to_email allCfg."${n}" host) cfg.targets);
+    mails_to_receive = builtins.concatStringsSep "," (map (n: "${to_email cfg n}:${n}") reverseTargets);
+    command = if cfg.local
+    then
+      [ "check_emails_local" "/var/lib/naemon/checks/email" mails_to_send mails_to_receive ]
+    else
+      [ "check_emails" cfg.login cfg.port mails_to_send mails_to_receive ];
+  in
+    {
+      service_description = "${hostFQDN} email service is active";
+      use = "mail-service";
+      host_name = hostFQDN;
+      servicegroups = "webstatus-email";
+      check_command = command;
+    };
+  otherObjects = map
+    (n: (pkgs.callPackage (./. + "/objects_" + n + ".nix") { inherit emailCheck; }))
+    [ "caldance-1" "ulminfo-fr" "phare" "tiboqorl-fr" ];
+  masterObjects = pkgs.callPackage ./objects_master.nix { inherit config; };
   commonObjects = pkgs.callPackage ./objects_common.nix ({
-    inherit hostFQDN;
+    master = cfg.master;
+    hostFQDN = config.hostEnv.fqdn;
+    hostName = name;
     sudo = "/run/wrappers/bin/sudo";
   } // builtins.getAttr name commonConfig);
   hostObjects =
     let
       specific_file = ./. + "/objects_" + name + ".nix";
     in
-      lib.attrsets.optionalAttrs (builtins.pathExists specific_file) (pkgs.callPackage specific_file { inherit config; });
+      lib.attrsets.optionalAttrs
+        (builtins.pathExists specific_file)
+        (pkgs.callPackage specific_file {
+          inherit config emailCheck;
+          hostFQDN = config.hostEnv.fqdn;
+          hostName = name;
+        });
 in
 {
   options = {
@@ -57,10 +151,27 @@ in
           Whether to enable monitoring.
         '';
       };
+      master = lib.mkOption {
+        type = lib.types.bool;
+        default = false;
+        description = ''
+          This instance is the master instance
+        '';
+      };
+      hosts = lib.mkOption {
+        readOnly = true;
+        description = "Hosts list for this host";
+        default = (commonObjects.host or {}) // (hostObjects.host or {});
+      };
+      services = lib.mkOption {
+        readOnly = true;
+        description = "Services list for this host";
+        default = commonObjects.service ++ hostObjects.service;
+      };
     };
   };
 
-  config = lib.mkIf config.myServices.monitoring.enable {
+  config = lib.mkIf cfg.enable {
     services.duplyBackup.profiles.monitoring = {
       rootDir = config.services.naemon.varDir;
     };
@@ -113,29 +224,58 @@ in
       enable = true;
       mode = "0644";
       user = "root";
-      text = "MAILADDR ${myconfig.env.monitoring.email}";
+      text = "MAILADDR ${config.myEnv.monitoring.email}";
     };
 
+    secrets.keys = [
+      {
+        dest = "naemon/id_rsa";
+        user = "naemon";
+        group = "naemon";
+        premissions = "0400";
+        text = config.myEnv.monitoring.ssh_secret_key;
+      }
+    ];
     # needed since extraResource is not in the closure
     systemd.services.naemon.path = [ myplugins ];
     services.naemon = {
       enable = true;
       extraConfig = ''
-        broker_module=${pkgs.naemon-livestatus}/lib/naemon-livestatus/livestatus.so ${config.services.naemon.runDir}/live
         use_syslog=1
         log_initial_states=1
         date_format=iso8601
-        admin_email=${myconfig.env.monitoring.email}
-
+        admin_email=${config.myEnv.monitoring.email}
+      '' + lib.optionalString (!cfg.master) ''
         obsess_over_services=1
         ocsp_command=notify-master
+      '' + lib.optionalString (cfg.master) ''
+        broker_module=${pkgs.naemon-livestatus}/lib/naemon-livestatus/livestatus.so ${config.services.naemon.runDir}/live
+        broker_module=${pkgs.status_engine.module}/lib/status-engine/naemon/statusengine-${pkgs.naemon.status_engine_version}.o use_service_perfdata=1 use_process_data=0 use_system_command_data=0 use_external_command_data=0 use_flapping_data=0 use_program_status_data=0 use_notification_data=0 use_contact_status_data=0 use_contact_notification_data=0 use_event_handler_data=0 use_object_data=0
       '';
       extraResource = ''
         $USER2$=${myplugins}
-        $USER200$=${myconfig.env.monitoring.status_url}
-        $USER201$=${myconfig.env.monitoring.status_token}
+        $USER200$=${config.myEnv.monitoring.status_url}
+        $USER201$=${config.myEnv.monitoring.status_token}
+        $USER202$=${config.myEnv.monitoring.http_user_password}
+        $USER203$=${config.secrets.fullPaths."naemon/id_rsa"}
+        $USER204$=${config.myEnv.monitoring.imap_login}
+        $USER205$=${config.myEnv.monitoring.imap_password}
+        $USER206$=${config.myEnv.monitoring.slack_channel}
+        $USER207$=${config.myEnv.monitoring.slack_url}
+        $USER208$=${builtins.concatStringsSep "," (map (builtins.concatStringsSep ":") config.myEnv.monitoring.eriomem_keys)}
+        $USER209$=${builtins.concatStringsSep "," [
+          config.myEnv.monitoring.ovh_sms.endpoint
+          config.myEnv.monitoring.ovh_sms.application_key
+          config.myEnv.monitoring.ovh_sms.application_secret
+          config.myEnv.monitoring.ovh_sms.consumer_key
+          config.myEnv.monitoring.ovh_sms.account
+        ]}
       '';
-      objectDefs = toObjects commonObjects + toObjects hostObjects;
+      objectDefs = toObjects commonObjects
+        + toObjects hostObjects
+        + lib.optionalString cfg.master (toObjects masterObjects)
+        + lib.optionalString cfg.master (toObjects masterPassiveObjects)
+        + lib.optionalString cfg.master (builtins.concatStringsSep "\n" (map toObjects otherObjects));
     };
   };
 }