]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/default.nix
Add Eban monitoring
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
index c573af212b924031534a7fb92babaf63295382ce..73e427554bcc5ce6d3372f419c63bd41daabbdfa 100644 (file)
@@ -16,13 +16,21 @@ let
     else if config.myServices.databases.enable
     then config.myServices.databases.postgresql.package
     else pkgs.postgresql;
+  zfsPlugin = pkgs.fetchurl {
+    url = "https://www.claudiokuenzler.com/monitoring-plugins/check_zpools.sh";
+    sha256 = "0p9ms9340in80jkds4kfspw62xnzsv5s7ni9m28kxyd0bnzkbzhf";
+  };
   myplugins = pkgs.runCommand "buildplugins" {
     buildInputs = [ pkgs.makeWrapper pkgs.perl ];
   } ''
     mkdir $out
+    cp ${zfsPlugin} $out/check_zpool.sh && chmod +x $out/check_zpool.sh
     cp ${./plugins}/* $out/
     patchShebangs $out
     wrapProgram $out/check_command --prefix PATH : ${config.security.wrapperDir}
+    wrapProgram $out/check_zpool.sh --prefix PATH : ${lib.makeBinPath [
+      pkgs.which pkgs.zfs pkgs.gawk
+    ]}
     wrapProgram $out/send_nrdp.sh --prefix PATH : ${lib.makeBinPath [
       pkgs.curl pkgs.jq
     ]}
@@ -70,6 +78,9 @@ let
     wrapProgram $out/notify_by_slack --prefix PATH : ${lib.makeBinPath [
       pkgs.curl pkgs.jq
     ]}
+    wrapProgram $out/notify_eban_url --prefix PATH : ${lib.makeBinPath [
+      pkgs.curl
+    ]}
     wrapProgram $out/check_ovh_sms --prefix PATH : ${lib.makeBinPath [
       (pkgs.python3.withPackages (ps: [ps.ovh]))
     ]}
@@ -79,6 +90,11 @@ let
     '';
   toObjects = pkgs.callPackage ./to_objects.nix {};
   commonConfig = {
+    dilion = {
+      processWarn = "250"; processAlert = "400";
+      loadWarn = "8.0"; loadAlert = "10.0";
+      interface = "eth0";
+    };
     eldiron = {
       processWarn = "250"; processAlert = "400";
       loadWarn = "8.0"; loadAlert = "10.0";
@@ -91,14 +107,20 @@ let
     };
     monitoring-1 = {
       processWarn = "50"; processAlert = "60";
-      loadWarn = "1.0"; loadAlert = "2.0";
+      loadWarn = "4.0"; loadAlert = "6.0";
+      load15Warn = "1.0"; load15Alert = "2.0";
       interface = "ens3";
     };
+    quatresaisons = {
+      processWarn = "250"; processAlert = "400";
+      loadWarn = "8.0"; loadAlert = "10.0";
+      interface = "eth0";
+    };
   };
   externalObjects = lib.genAttrs [ "tiboqorl-fr" ]
     (n: pkgs.callPackage (./. + "/objects_" + n + ".nix") { inherit emailCheck; });
   masterPassiveObjects = let
-    passiveNodes = lib.attrsets.filterAttrs (n: _: builtins.elem n ["backup-2" "eldiron"]) nodes;
+    passiveNodes = lib.attrsets.filterAttrs (n: _: builtins.elem n ["backup-2" "eldiron" "quatresaisons" "dilion"]) nodes;
     toPassiveServices = map (s: s.passiveInfo.filter s // s.passiveInfo);
     passiveServices = lib.flatten (lib.attrsets.mapAttrsToList
       (_: n: toPassiveServices n.config.myServices.monitoring.services)
@@ -138,7 +160,7 @@ let
     };
   otherObjects = map
     (n: (pkgs.callPackage (./. + "/objects_" + n + ".nix") { inherit emailCheck; }))
-    [ "caldance-1" "ulminfo-fr" "phare" ];
+    [ "ulminfo-fr" "phare" "eban" ];
   masterObjects = pkgs.callPackage ./objects_master.nix { inherit config; };
   commonObjects = pkgs.callPackage ./objects_common.nix ({
     master = cfg.master;
@@ -307,6 +329,7 @@ in
           config.myEnv.monitoring.ovh_sms.consumer_key
           config.myEnv.monitoring.ovh_sms.account
         ]}
+        $USER210$=${config.myEnv.monitoring.eban.password}
       '';
       objectDefs = toObjects commonObjects
         + toObjects hostObjects