]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/default.nix
Small adjustments for naemon and web server
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
index 73e427554bcc5ce6d3372f419c63bd41daabbdfa..5f8a8c9a40099ccacd43ef04f8d871437b33e3fe 100644 (file)
@@ -20,11 +20,28 @@ let
     url = "https://www.claudiokuenzler.com/monitoring-plugins/check_zpools.sh";
     sha256 = "0p9ms9340in80jkds4kfspw62xnzsv5s7ni9m28kxyd0bnzkbzhf";
   };
+  megacli = pkgs.megacli.overrideAttrs(old: { meta = old.meta // { license = null; }; });
+  megaCliPlugin = pkgs.runCommand "megaCliPlugin" {
+    plugin = pkgs.fetchurl {
+      name = "check_megaraid_sas";
+      url = "https://exchange.nagios.org/components/com_mtree/attachment.php?link_id=6381&cf_id=24";
+      sha256 = "0yf60p4c0hb4q3fng9fc14qc89bqm0f1sijayzygadaqcl44jx4p";
+    };
+  } ''
+    mkdir $out
+    cp $plugin $out/check_megaraid_sas
+    chmod +x $out/check_megaraid_sas
+    patchShebangs $out
+    substituteInPlace $out/check_megaraid_sas --replace /usr/sbin/MegaCli ${megacli}/bin/MegaCli64
+    substituteInPlace $out/check_megaraid_sas --replace 'sudo $megacli' '/run/wrappers/bin/sudo $megacli'
+    sed -i -e "s/use utils qw(%ERRORS);/my %ERRORS = ('OK' => 0, 'WARNING' => 1, 'CRITICAL' => 2, 'UNKNOWN' => 3);/" $out/check_megaraid_sas
+  '';
   myplugins = pkgs.runCommand "buildplugins" {
     buildInputs = [ pkgs.makeWrapper pkgs.perl ];
   } ''
     mkdir $out
     cp ${zfsPlugin} $out/check_zpool.sh && chmod +x $out/check_zpool.sh
+    cp ${megaCliPlugin}/check_megaraid_sas $out/
     cp ${./plugins}/* $out/
     patchShebangs $out
     wrapProgram $out/check_command --prefix PATH : ${config.security.wrapperDir}
@@ -92,12 +109,12 @@ let
   commonConfig = {
     dilion = {
       processWarn = "250"; processAlert = "400";
-      loadWarn = "8.0"; loadAlert = "10.0";
+      loadWarn = "1.0"; loadAlert = "1.2";
       interface = "eth0";
     };
     eldiron = {
       processWarn = "250"; processAlert = "400";
-      loadWarn = "8.0"; loadAlert = "10.0";
+      loadWarn = "1.0"; loadAlert = "1.2";
       interface = "eth0";
     };
     backup-2 = {
@@ -113,7 +130,7 @@ let
     };
     quatresaisons = {
       processWarn = "250"; processAlert = "400";
-      loadWarn = "8.0"; loadAlert = "10.0";
+      loadWarn = "1.0"; loadAlert = "1.2";
       interface = "eth0";
     };
   };
@@ -215,7 +232,32 @@ in
 
   config = lib.mkIf cfg.enable {
     services.nginx = lib.mkIf config.myServices.status.enable {
-      virtualHosts."status.immae.eu".locations = objectsFiles;
+      virtualHosts."status.immae.eu".locations = objectsFiles // {
+        "=/common/immae.cfg" = {
+          alias = pkgs.writeText "immae.cfg" ''
+            # put me for instance in /etc/naemon/module-conf.d/immae.cfg
+            # Make sure that you have include_dir=module-conf.d in
+            # naemon.cfg
+            log_initial_states=1
+            date_format=iso8601
+            admin_email=${config.myEnv.monitoring.email}
+            obsess_over_services=1
+            ocsp_command=notify-master
+          '';
+        };
+        "=/common/resource.cfg" = {
+          alias = pkgs.writeText "resource.cfg" ''
+            # Resource.cfg file
+            # Replace this with path to monitoring plugins
+            $USER1$=@@COMMON_PLUGINS@@
+            # Replace this with a path to scripts from
+            # https://git.immae.eu/cgit/perso/Immae/Config/Nix.git/tree/modules/private/monitoring/plugins
+            $USER2$=@@IMMAE_PLUGINS@@
+            $USER200$=https://status.immae.eu/
+            $USER201$=@@TOKEN@@
+          '';
+        };
+      };
     };
 
     services.duplyBackup.profiles.monitoring = {
@@ -226,6 +268,7 @@ in
         commands = [
           { command = "${pkgs.mdadm}/bin/mdadm --monitor --scan -1"; options = [ "NOPASSWD" ]; }
           { command = "${pkgs.postfix}/bin/mailq"; options = [ "NOPASSWD" ]; }
+          { command = "${megacli}/bin/MegaCli64"; options = [ "NOPASSWD" ]; }
         ];
         users = [ "naemon" ];
         runAs = "root";
@@ -329,7 +372,8 @@ in
           config.myEnv.monitoring.ovh_sms.consumer_key
           config.myEnv.monitoring.ovh_sms.account
         ]}
-        $USER210$=${config.myEnv.monitoring.eban.password}
+        $USER210$=${config.myEnv.monitoring.eban.user}
+        $USER211$=${config.myEnv.monitoring.eban.password}
       '';
       objectDefs = toObjects commonObjects
         + toObjects hostObjects