]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/default.nix
Add megaraid monitoring
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
index 73e427554bcc5ce6d3372f419c63bd41daabbdfa..342c7f7a53591049af881c5ed5c105c66f7ed508 100644 (file)
@@ -20,11 +20,28 @@ let
     url = "https://www.claudiokuenzler.com/monitoring-plugins/check_zpools.sh";
     sha256 = "0p9ms9340in80jkds4kfspw62xnzsv5s7ni9m28kxyd0bnzkbzhf";
   };
+  megacli = pkgs.megacli.overrideAttrs(old: { meta = old.meta // { license = null; }; });
+  megaCliPlugin = pkgs.runCommand "megaCliPlugin" {
+    plugin = pkgs.fetchurl {
+      name = "check_megaraid_sas";
+      url = "https://exchange.nagios.org/components/com_mtree/attachment.php?link_id=6381&cf_id=24";
+      sha256 = "0yf60p4c0hb4q3fng9fc14qc89bqm0f1sijayzygadaqcl44jx4p";
+    };
+  } ''
+    mkdir $out
+    cp $plugin $out/check_megaraid_sas
+    chmod +x $out/check_megaraid_sas
+    patchShebangs $out
+    substituteInPlace $out/check_megaraid_sas --replace /usr/sbin/MegaCli ${megacli}/bin/MegaCli64
+    substituteInPlace $out/check_megaraid_sas --replace 'sudo $megacli' '/run/wrappers/bin/sudo $megacli'
+    sed -i -e "s/use utils qw(%ERRORS);/my %ERRORS = ('OK' => 0, 'WARNING' => 1, 'CRITICAL' => 2, 'UNKNOWN' => 3);/" $out/check_megaraid_sas
+  '';
   myplugins = pkgs.runCommand "buildplugins" {
     buildInputs = [ pkgs.makeWrapper pkgs.perl ];
   } ''
     mkdir $out
     cp ${zfsPlugin} $out/check_zpool.sh && chmod +x $out/check_zpool.sh
+    cp ${megaCliPlugin}/check_megaraid_sas $out/
     cp ${./plugins}/* $out/
     patchShebangs $out
     wrapProgram $out/check_command --prefix PATH : ${config.security.wrapperDir}
@@ -226,6 +243,7 @@ in
         commands = [
           { command = "${pkgs.mdadm}/bin/mdadm --monitor --scan -1"; options = [ "NOPASSWD" ]; }
           { command = "${pkgs.postfix}/bin/mailq"; options = [ "NOPASSWD" ]; }
+          { command = "${megacli}/bin/MegaCli64"; options = [ "NOPASSWD" ]; }
         ];
         users = [ "naemon" ];
         runAs = "root";