]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/mail/postfix.nix
Move postscript scripts sensible values out of the store
[perso/Immae/Config/Nix.git] / modules / private / mail / postfix.nix
index 985d4af084d8784d470f9122aa8e7ca5bc2105fd..70c3f466f7376b204e62f32319bd008c3d4a255c 100644 (file)
@@ -18,7 +18,7 @@
           hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
           dbname = ${config.myEnv.mail.postfix.mysql.database}
           query = SELECT DISTINCT destination
-            FROM forwardings_merge
+            FROM forwardings
             WHERE
               ((regex = 1 AND '%s' REGEXP CONCAT('^',source,'$') ) OR (regex = 0 AND source = '%s'))
               AND active = 1
           '';
       }
       {
-        dest = "postfix/mysql_mailbox_maps";
+        dest = "postfix/ldap_mailboxes";
         user = config.services.postfix.user;
         group = config.services.postfix.group;
         permissions = "0440";
         text = ''
-          # We need to specify that option to trigger ssl connection
-          tls_ciphers = TLSv1.2
-          user = ${config.myEnv.mail.postfix.mysql.user}
-          password = ${config.myEnv.mail.postfix.mysql.password}
-          hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
-          dbname = ${config.myEnv.mail.postfix.mysql.database}
-          result_format = /%d/%u
-          query = SELECT DISTINCT '%s'
-            FROM mailboxes
-            WHERE active = 1
-            AND (
-              (domain = '%d' AND user = '%u' AND regex = 0)
-              OR (
-                regex = 1
-                AND '%d' REGEXP CONCAT('^',domain,'$')
-                AND '%u' REGEXP CONCAT('^',user,'$')
-              )
-            )
-            LIMIT 1
+          server_host = ldaps://${config.myEnv.mail.dovecot.ldap.host}:636
+          search_base = ${config.myEnv.mail.dovecot.ldap.base}
+          query_filter = ${config.myEnv.mail.dovecot.ldap.postfix_mailbox_filter}
+          bind_dn = ${config.myEnv.mail.dovecot.ldap.dn}
+          bind_pw = ${config.myEnv.mail.dovecot.ldap.password}
+          result_attribute = immaePostfixAddress
+          result_format = dummy
+          version = 3
         '';
       }
       {
           hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
           dbname = ${config.myEnv.mail.postfix.mysql.database}
           query = SELECT DISTINCT destination
-            FROM forwardings_merge
+            FROM forwardings
             WHERE
-              ((regex = 1 AND '%s' REGEXP CONCAT('^',source,'$') ) OR (regex = 0 AND source = '%s'))
+              (
+                (regex = 1 AND CONCAT(SUBSTRING_INDEX('%u', '+', 1), '@%d') REGEXP CONCAT('^',source,'$') )
+              OR
+                (regex = 0 AND source = CONCAT(SUBSTRING_INDEX('%u', '+', 1), '@%d'))
+              )
               AND active = 1
-            UNION SELECT '%s' AS destination
+            UNION SELECT CONCAT(SUBSTRING_INDEX('%u', '+', 1), '@%d') AS destination
           '';
       }
       {
           version = 3
           '';
       }
-    ];
+    ] ++ (lib.mapAttrsToList (name: v: {
+      dest = "postfix/scripts/${name}-env";
+      user = "postfixscripts";
+      group = "root";
+      permissions = "0400";
+      text = builtins.toJSON v.env;
+    }) config.myEnv.mail.scripts);
 
     networking.firewall.allowedTCPPorts = [ 25 465 587 ];
 
+    users.users.postfixscripts = {
+      group = "keys";
+      uid = config.ids.uids.postfixscripts;
+      description = "Postfix scripts user";
+    };
     users.users."${config.services.postfix.user}".extraGroups = [ "keys" ];
     services.filesWatcher.postfix = {
       restart = true;
       paths = [
         config.secrets.fullPaths."postfix/mysql_alias_maps"
-        config.secrets.fullPaths."postfix/mysql_mailbox_maps"
+        config.secrets.fullPaths."postfix/ldap_mailboxes"
         config.secrets.fullPaths."postfix/mysql_sender_login_maps"
         config.secrets.fullPaths."postfix/ldap_ejabberd_users_immae_fr"
       ];
           fi
           '';
         scripts = lib.attrsets.mapAttrs (n: v:
-          toScript n (pkgs.callPackage (builtins.fetchGit { url = v.src.url; ref = "master"; rev = v.src.rev; }) { scriptEnv = v.env; })
+          toScript n (pkgs.callPackage (builtins.fetchGit { url = v.src.url; ref = "master"; rev = v.src.rev; }) { scriptEnv = "/var/secrets/postfix/scripts/${n}-env"; })
         ) config.myEnv.mail.scripts // {
           testmail = pkgs.writeScript "testmail" ''
             #! ${pkgs.stdenv.shell}
             joined = builtins.concatStringsSep ",";
           in pkgs.writeText "host-sender-login"
             (builtins.concatStringsSep "\n" (mapAttrsToList (n: v: "${n} ${joined v}") addresses));
-          host_dummy_mailboxes = pkgs.writeText "host-virtual-mailbox"
-            (builtins.concatStringsSep "\n" (["immae-eu@immae.eu dummy"] ++ lib.attrsets.mapAttrsToList (n: v: "${n}@immae.eu  dummy") nodes));
         };
       in
         recipient_maps // relay_restrictions // virtual_map // sasl_access;
         mailbox_size_limit = "1073741825"; # Workaround, local delivered mails should all go through scripts
         alias_database = "\$alias_maps";
 
+        ### Aliases scripts user
+        default_privs = "postfixscripts";
+
         ### Virtual mailboxes config
-        virtual_alias_maps = "hash:/etc/postfix/virtual mysql:${config.secrets.fullPaths."postfix/mysql_alias_maps"} ldap:${config.secrets.fullPaths."postfix/ldap_ejabberd_users_immae_fr"}";
+        virtual_alias_maps = [
+          "hash:/etc/postfix/virtual"
+          "mysql:${config.secrets.fullPaths."postfix/mysql_alias_maps"}"
+          "ldap:${config.secrets.fullPaths."postfix/ldap_ejabberd_users_immae_fr"}"
+        ];
         virtual_mailbox_domains = config.myEnv.mail.postfix.additional_mailbox_domains
         ++ lib.remove null (lib.flatten (map
             (zone: map
             )
             config.myEnv.dns.masterZones
           ));
-        virtual_mailbox_maps = "hash:/etc/postfix/host_dummy_mailboxes mysql:${config.secrets.fullPaths."postfix/mysql_mailbox_maps"}";
+        virtual_mailbox_maps = [
+          "ldap:${config.secrets.fullPaths."postfix/ldap_mailboxes"}"
+        ];
         dovecot_destination_recipient_limit = "1";
         virtual_transport = "dovecot";
 
         smtp_use_tls = true;
         smtpd_use_tls = true;
         smtpd_tls_chain_files = builtins.concatStringsSep "," [ "/var/lib/acme/mail/full.pem" "/var/lib/acme/mail-rsa/full.pem" ];
+
+        maximal_queue_lifetime = "6w";
+        bounce_queue_lifetime = "6w";
       };
       enable = true;
       enableSmtp = true;
                 ${pkgs.dovecot}/libexec/dovecot/dovecot-lda -f "$sender" -a "$original_recipient" -d "$user"
               '';
           in [
-            "flags=DRhu" "user=vhost:vhost"
+            "flags=ODRhu" "user=vhost:vhost"
             "argv=${rspamc_dovecot}/bin/rspamc_dovecot \${sender} \${original_recipient} \${user}@\${nexthop}"
           ];
         };
         "smtp.immae.eu" = null;
       };
     };
+    security.acme.certs."mail-rsa" = {
+      postRun = ''
+        systemctl restart postfix.service
+        '';
+      extraDomains = {
+        "smtp.immae.eu" = null;
+      };
+    };
     system.activationScripts.testmail = {
       deps = [ "users" ];
       text = let
           in "${cfg'.mail_address}${sep}${host'}@${cfg'.mail_domain}";
         mails_to_receive = builtins.concatStringsSep " " (map (to_email cfg) reverseTargets);
       in ''
-        install -m 0555 -o nobody -g nogroup -d /var/lib/naemon/checks/email
+        install -m 0555 -o postfixscripts -g keys -d /var/lib/naemon/checks/email
         for f in ${mails_to_receive}; do
           if [ ! -f /var/lib/naemon/checks/email/$f ]; then
-            install -m 0644 -o nobody -g nogroup /dev/null -T /var/lib/naemon/checks/email/$f
+            install -m 0644 -o postfixscripts -g keys /dev/null -T /var/lib/naemon/checks/email/$f
             touch -m -d @0 /var/lib/naemon/checks/email/$f
           fi
         done
         '';
     };
+    systemd.services.postfix.serviceConfig.Slice = "mail.slice";
   };
 }