]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add Richie website
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 2aa8b5e272c9a9f9924e447cbed7be0594bcaa9a..f0e39e9ca3d70aa64acfc030f588587f4fdee3ea 100644 (file)
@@ -1104,6 +1104,23 @@ in
                   };
                 };
           };
+          richie = mkOption {
+            description = "Europe Richie configurations by environment";
+            type = submodule {
+              options = {
+                mysql = mkMysqlOptions "Richie";
+                smtp_mailer = mkOption {
+                  description = "SMTP mailer configuration";
+                  type = submodule {
+                    options = {
+                      user = mkOption { type = str; description = "Username"; };
+                      password = mkOption { type = str; description = "Password"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           tellesflorian = mkOption {
             description = "Tellesflorian configurations by environment";
             type =