]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
First attempt at making declarative VMs
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 719bf8f01b9b4cf6cbe996f7ad36c8e05b1411b8..f0af57203145b472cf0929cace8205740045e842 100644 (file)
@@ -228,6 +228,7 @@ in
       '';
       type = submodule {
         options = {
+          rootKeys = mkOption { type = attrsOf str; description = "Keys of root users"; };
           ldap = mkOption {
             description = ''
               LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn
@@ -804,6 +805,7 @@ in
       description = "Buildbot configuration";
       type = submodule {
         options = {
+          workerPassword = mkOption { description = "Buildbot worker password"; type = str; };
           user = mkOption {
             description = "Buildbot user";
             type = submodule {
@@ -855,6 +857,7 @@ in
                     '';
                 };
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
+                workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {
                   type = attrsOf str;
                   description = "Secrets for the project to dump as files";