]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
First attempt at making declarative VMs
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 32af33989b6d5af31d53029485c9b73da4ceda06..f0af57203145b472cf0929cace8205740045e842 100644 (file)
@@ -228,6 +228,7 @@ in
       '';
       type = submodule {
         options = {
+          rootKeys = mkOption { type = attrsOf str; description = "Keys of root users"; };
           ldap = mkOption {
             description = ''
               LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn
@@ -804,6 +805,7 @@ in
       description = "Buildbot configuration";
       type = submodule {
         options = {
+          workerPassword = mkOption { description = "Buildbot worker password"; type = str; };
           user = mkOption {
             description = "Buildbot user";
             type = submodule {
@@ -855,6 +857,7 @@ in
                     '';
                 };
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
+                workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {
                   type = attrsOf str;
                   description = "Secrets for the project to dump as files";
@@ -1165,6 +1168,16 @@ in
               };
             };
           };
+          cryptpad = mkOption {
+            description = "Cryptpad configuration";
+            type = attrsOf (submodule {
+              options = {
+                email = mkOption { type = str; description = "Admin e-mail"; };
+                admins = mkOption { type = listOf str; description = "Instance admin public keys"; };
+                port = mkOption { type = port; description = "Port to listen to"; };
+              };
+            });
+          };
           ympd = mkOption {
             description = "Ympd configuration";
             type = submodule {
@@ -1183,6 +1196,16 @@ in
               };
             };
           };
+          umami = mkOption {
+            description = "Umami configuration";
+            type = submodule {
+              options = {
+                listenPort = mkOption { type = port; description = "Port to listen to"; };
+                postgresql = mkPsqlOptions "Umami";
+                hashSalt = mkOption { type = str; description = "Hash salt"; };
+              };
+            };
+          };
           yourls = mkOption {
             description = "Yourls configuration";
             type = submodule {