]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add check_command for backups
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 5d74ab555aff23f1e8f70f8922760ca775ee2844..ec9bf29f3c5d2736a2822482f2eed75b5cabd52a 100644 (file)
@@ -450,6 +450,7 @@ in
             type = attrsOf (submodule {
               options = {
                 keep = mkOption { type = int; description = "Number of backups to keep"; };
+                check_command = mkOption { type = str; description = "command to check if backup needs to be done"; default = "backup"; };
                 login = mkOption { type = str; description = "Login to connect to host"; };
                 port = mkOption { type = str; default = "22"; description = "Port to connect to host"; };
                 host = mkOption { type = str; description = "Host to connect to"; };