]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add CSP reports
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 3a805c601b7693cf87f3f68ab95e5dfc96bd1180..b8c4dd2325a89497decbdc876f0b73f1dc05601e 100644 (file)
@@ -1077,6 +1077,16 @@ in
             type = attrsOf str;
             description = "Mapping 'name'.php => script for webhooks";
           };
+          csp_reports = mkOption {
+            description = "CSP report configuration";
+            type = submodule {
+              options = {
+                report_uri = mkOption { type = str; description = "URI to report CSP violations to"; };
+                policies = mkOption { type = attrsOf str; description = "CSP policies to apply"; };
+                postgresql = mkPsqlOptions "CSP reports";
+              };
+            };
+          };
           commento = mkOption {
             description = "Commento configuration";
             type = submodule {