]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add netdata configuration
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 5d74ab555aff23f1e8f70f8922760ca775ee2844..a8799d26e492ef821edd7aae8d194b1bcf94b82f 100644 (file)
@@ -108,6 +108,19 @@ let
       };
     };
   };
+  smtpOptions = {
+    host = mkOption { description = "Host to access SMTP"; type = str; };
+    port = mkOption { description = "Port to access SMTP"; type = str; };
+  };
+  mkSmtpOptions = name: mkOption {
+    description = "${name} smtp configuration";
+    type = submodule {
+      options = smtpOptions // {
+        email = mkOption { description = "${name} email"; type = str; };
+        password = mkOption { description = "SMTP password of the ${name} user"; type = str; };
+      };
+    };
+  };
   hostEnv = submodule {
     options = {
       fqdn = mkOption {
@@ -258,6 +271,10 @@ in
         };
       };
     };
+    smtp = mkOption {
+      type = submodule { options = smtpOptions; };
+      description = "SMTP configuration";
+    };
     ldap = mkOption {
       description = ''
         LDAP server configuration
@@ -424,9 +441,40 @@ in
       type = submodule {
         options = {
           password = mkOption { type = str; description = "Password for encrypting files"; };
-          remote = mkOption { type = str; description = "Remote url access"; };
-          accessKeyId = mkOption { type = str; description = "Remote access-key"; };
-          secretAccessKey = mkOption { type = str; description = "Remote access secret"; };
+          remotes = mkOption {
+            type = attrsOf (submodule {
+              options = {
+                remote = mkOption {
+                  type = unspecified;
+                  example = literalExample ''
+                    bucket: "s3://some_host/${bucket}";
+                    '';
+                  description = ''
+                    Function.
+                    Takes a bucket name as argument and returns a url
+                    '';
+                };
+                accessKeyId = mkOption { type = str; description = "Remote access-key"; };
+                secretAccessKey = mkOption { type = str; description = "Remote access secret"; };
+              };
+            });
+          };
+        };
+      };
+    };
+    zrepl_backup = mkOption {
+      type = submodule {
+        options = {
+          ssh_key = mkOption {
+            description = "SSH key information";
+            type = submodule {
+              options = {
+                public = mkOption { type = str; description = "Public part of the key"; };
+                private = mkOption { type = lines; description = "Private part of the key"; };
+              };
+            };
+          };
+          mysql = mkMysqlOptions "Zrepl" {};
         };
       };
     };
@@ -450,6 +498,7 @@ in
             type = attrsOf (submodule {
               options = {
                 keep = mkOption { type = int; description = "Number of backups to keep"; };
+                check_command = mkOption { type = str; description = "command to check if backup needs to be done"; default = "backup"; };
                 login = mkOption { type = str; description = "Login to connect to host"; };
                 port = mkOption { type = str; default = "22"; description = "Port to connect to host"; };
                 host = mkOption { type = str; description = "Host to connect to"; };
@@ -512,6 +561,8 @@ in
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
           slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
           slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
+          netdata_aggregator = mkOption { type = str; description = "Url where netdata information should be sent"; };
+          netdata_keys = mkOption { type = attrsOf str; description = "netdata host keys"; };
           contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
           email_check = mkOption {
             description = "Emails services to check";
@@ -823,6 +874,16 @@ in
       type = submodule {
         options = {
           contact = mkOption { type = str; description = "Contact e-mail address"; };
+          assets = mkOption {
+            default = {};
+            type = attrsOf (submodule {
+              options = {
+                url = mkOption { type = str; description = "URL to fetch"; };
+                sha256 = mkOption { type = str; description = "Hash of the url"; };
+              };
+            });
+            description = "Assets to provide on assets.immae.eu";
+          };
           davical = mkOption {
             description = "Davical configuration";
             type = submodule {
@@ -1002,6 +1063,15 @@ in
               };
             };
           };
+          status_engine = mkOption {
+            description = "Status Engine configuration";
+            type = submodule {
+              options = {
+                mysql = mkMysqlOptions "StatusEngine" {};
+                ldap = mkLdapOptions "StatusEngine" {};
+              };
+            };
+          };
           task = mkOption {
             description = "Taskwarrior configuration";
             type = submodule {
@@ -1050,6 +1120,26 @@ in
             type = attrsOf str;
             description = "Mapping 'name'.php => script for webhooks";
           };
+          csp_reports = mkOption {
+            description = "CSP report configuration";
+            type = submodule {
+              options = {
+                report_uri = mkOption { type = str; description = "URI to report CSP violations to"; };
+                policies = mkOption { type = attrsOf str; description = "CSP policies to apply"; };
+                postgresql = mkPsqlOptions "CSP reports";
+              };
+            };
+          };
+          commento = mkOption {
+            description = "Commento configuration";
+            type = submodule {
+              options = {
+                listenPort = mkOption { type = port; description = "Port to listen to"; };
+                postgresql = mkPsqlOptions "Commento";
+                smtp = mkSmtpOptions "Commento";
+              };
+            };
+          };
           ympd = mkOption {
             description = "Ympd configuration";
             type = submodule {
@@ -1282,6 +1372,21 @@ in
               };
             };
           };
+          caldance = mkOption {
+            description = "Caldance configurations by environment";
+            type = submodule {
+              options = {
+                integration = mkOption {
+                  description = "environment configuration";
+                  type = submodule {
+                    options = {
+                      password = mkOption { type = str; description = "Password file content for basic auth"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           tellesflorian = mkOption {
             description = "Tellesflorian configurations by environment";
             type =