]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add xmpp-mail bridge
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 2aa8b5e272c9a9f9924e447cbed7be0594bcaa9a..9bfb80a7609a7c2926e3894ef6311385150f1298 100644 (file)
@@ -259,6 +259,7 @@ in
       description = "Jabber configuration";
       type = submodule {
         options = {
+          postfix_user_filter = mkOption { type = str; description = "Postfix filter to get xmpp users"; };
           ldap = mkLdapOptions "Jabber" {};
           postgresql = mkPsqlOptions "Jabber";
         };
@@ -593,6 +594,7 @@ in
             description = "Mail script recipients";
             type = attrsOf (submodule {
               options = {
+                external = mkEnableOption "Create a script_<name>@mail.immae.eu external address";
                 src = mkOption {
                   description = ''
                     git source to fetch the script from.
@@ -951,8 +953,8 @@ in
       description = "Websites configurations";
       type = submodule {
         options = {
-          aten = mkOption {
-            description = "Aten configurations by environment";
+          isabelle = mkOption {
+            description = "Isabelle configurations by environment";
             type =
               let
                 atenSubmodule = mkOption {
@@ -968,8 +970,8 @@ in
               in
                 submodule {
                   options = {
-                    production = atenSubmodule;
-                    integration = atenSubmodule;
+                    aten_production = atenSubmodule;
+                    aten_integration = atenSubmodule;
                   };
                 };
           };
@@ -1104,6 +1106,23 @@ in
                   };
                 };
           };
+          richie = mkOption {
+            description = "Europe Richie configurations by environment";
+            type = submodule {
+              options = {
+                mysql = mkMysqlOptions "Richie";
+                smtp_mailer = mkOption {
+                  description = "SMTP mailer configuration";
+                  type = submodule {
+                    options = {
+                      user = mkOption { type = str; description = "Username"; };
+                      password = mkOption { type = str; description = "Password"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           tellesflorian = mkOption {
             description = "Tellesflorian configurations by environment";
             type =