]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add cryptpad farm
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index e79feec573e2273e3471cc3d2f0b362f397173ae..980b87830a500eccb7380698a8b9ef2270d5f098 100644 (file)
@@ -384,6 +384,16 @@ in
             };
             type = attrsOf (attrsOf (listOf str));
           };
+          keys = mkOption {
+            default = {};
+            description = "DNS keys";
+            type = attrsOf (submodule {
+              options = {
+                algorithm = mkOption { type = str; description = "Algorithm"; };
+                secret    = mkOption { type = str; description = "Secret"; };
+              };
+            });
+          };
           slaveZones = mkOption {
             description = "List of slave zones";
             type = listOf (submodule {
@@ -393,6 +403,11 @@ in
                   description = "NS master groups of this zone";
                   type = listOf str;
                 };
+                keys = mkOption {
+                  default = [];
+                  description = "Keys associated to the server";
+                  type = listOf str;
+                };
               };
             });
           };
@@ -401,6 +416,7 @@ in
             type = listOf (submodule {
               options = {
                 name = mkOption { type = str; description = "zone name"; };
+                withCAA = mkOption { type = nullOr str; description = "CAA entry"; default = null; };
                 slaves = mkOption {
                   description = "NS slave groups of this zone";
                   type = listOf str;
@@ -558,6 +574,15 @@ in
               };
             };
           };
+          eban = mkOption {
+            description = "Eban credentials for webhook";
+            type = submodule {
+              options = {
+                user = mkOption { type = str; description = "User"; };
+                password = mkOption { type = str; description = "Password"; };
+              };
+            };
+          };
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
           slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
           slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
@@ -1140,6 +1165,16 @@ in
               };
             };
           };
+          cryptpad = mkOption {
+            description = "Cryptpad configuration";
+            type = attrsOf (submodule {
+              options = {
+                email = mkOption { type = str; description = "Admin e-mail"; };
+                admins = mkOption { type = listOf str; description = "Instance admin public keys"; };
+                port = mkOption { type = port; description = "Port to listen to"; };
+              };
+            });
+          };
           ympd = mkOption {
             description = "Ympd configuration";
             type = submodule {