]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Update Chloé’s website
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index f7994a1e7894c28be410e9df70382b554f005f11..969c9c776d5d36d95ccd95708567e9e0bc9cc2b6 100644 (file)
@@ -820,6 +820,15 @@ in
               };
             };
           };
+          dmarc_reports = mkOption {
+            description = "DMARC reports configuration";
+            type = submodule {
+              options = {
+                mysql = mkMysqlOptions "DMARC" {};
+                anonymous_key = mkOption { type = str; description = "Anonymous hashing key"; };
+              };
+            };
+          };
           etherpad-lite = mkOption {
             description = "Etherpad configuration";
             type = submodule {
@@ -828,6 +837,7 @@ in
                 ldap = mkLdapOptions "Etherpad" {
                   group_filter = mkOption { type = str; description = "Filter for groups"; };
                 };
+                adminPassword = mkOption { type = str; description = "Admin password for mypads / admin"; };
                 session_key = mkOption { type = str; description = "Session key"; };
                 api_key = mkOption { type = str; description = "API key"; };
                 redirects = mkOption { type = str; description = "Redirects for apache"; };