]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add CAA to dns
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 193e95cf81d8cd64b9e0731af9755b617b033e74..91e018d4f76e107ee1a849cbd5b4f6b68704708e 100644 (file)
@@ -401,6 +401,7 @@ in
             type = listOf (submodule {
               options = {
                 name = mkOption { type = str; description = "zone name"; };
+                withCAA = mkOption { type = nullOr str; description = "CAA entry"; default = null; };
                 slaves = mkOption {
                   description = "NS slave groups of this zone";
                   type = listOf str;
@@ -462,6 +463,22 @@ in
         };
       };
     };
+    zrepl_backup = mkOption {
+      type = submodule {
+        options = {
+          ssh_key = mkOption {
+            description = "SSH key information";
+            type = submodule {
+              options = {
+                public = mkOption { type = str; description = "Public part of the key"; };
+                private = mkOption { type = lines; description = "Private part of the key"; };
+              };
+            };
+          };
+          mysql = mkMysqlOptions "Zrepl" {};
+        };
+      };
+    };
     rsync_backup = mkOption {
       description  =''
         Rsync backup configuration from controlled host
@@ -542,9 +559,19 @@ in
               };
             };
           };
+          eban = mkOption {
+            description = "Eban credentials for webhook";
+            type = submodule {
+              options = {
+                password = mkOption { type = str; description = "Password"; };
+              };
+            };
+          };
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
           slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
           slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
+          netdata_aggregator = mkOption { type = str; description = "Url where netdata information should be sent"; };
+          netdata_keys = mkOption { type = attrsOf str; description = "netdata host keys"; };
           contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
           email_check = mkOption {
             description = "Emails services to check";
@@ -1153,6 +1180,7 @@ in
         };
       };
     };
+    serverSpecific = mkOption { type = attrsOf unspecified; description = "Server specific configuration"; };
     websites = mkOption {
       description = "Websites configurations";
       type = submodule {
@@ -1354,6 +1382,21 @@ in
               };
             };
           };
+          caldance = mkOption {
+            description = "Caldance configurations by environment";
+            type = submodule {
+              options = {
+                integration = mkOption {
+                  description = "environment configuration";
+                  type = submodule {
+                    options = {
+                      password = mkOption { type = str; description = "Password file content for basic auth"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           tellesflorian = mkOption {
             description = "Tellesflorian configurations by environment";
             type =