]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Migrate to proftpd
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index f0af57203145b472cf0929cace8205740045e842..837d24be95e65a9251ba93b54163fc48b6f4a113 100644 (file)
@@ -621,7 +621,10 @@ in
       description = "FTP configuration";
       type = submodule {
         options = {
-          ldap = mkLdapOptions "FTP" {};
+          ldap = mkLdapOptions "FTP" {
+            proftpd_filter = mkOption { type = str; description = "Filter for proftpd listing in LDAP"; };
+            pure-ftpd_filter = mkOption { type = str; description = "Filter for pure-ftpd listing in LDAP"; };
+          };
         };
       };
     };
@@ -805,6 +808,15 @@ in
       description = "Buildbot configuration";
       type = submodule {
         options = {
+          ssh_key = mkOption {
+            description = "SSH key information";
+            type = submodule {
+              options = {
+                public = mkOption { type = str; description = "Public part of the key"; };
+                private = mkOption { type = lines; description = "Private part of the key"; };
+              };
+            };
+          };
           workerPassword = mkOption { description = "Buildbot worker password"; type = str; };
           user = mkOption {
             description = "Buildbot user";
@@ -961,6 +973,15 @@ in
             type = submodule {
               options = {
                 ldap = mkLdapOptions "Gitolite" {};
+                ssh_key = mkOption {
+                  description = "SSH key information";
+                  type = submodule {
+                    options = {
+                      public = mkOption { type = str; description = "Public part of the key"; };
+                      private = mkOption { type = lines; description = "Private part of the key"; };
+                    };
+                  };
+                };
               };
             };
           };
@@ -1461,13 +1482,6 @@ in
         };
       };
     };
-
-    privateFiles = mkOption {
-      type = path;
-      description = ''
-        Path to secret files to make available during build
-        '';
-    };
   };
   options.hostEnv = mkOption {
     readOnly = true;