]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add umami
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 980b87830a500eccb7380698a8b9ef2270d5f098..719bf8f01b9b4cf6cbe996f7ad36c8e05b1411b8 100644 (file)
@@ -1193,6 +1193,16 @@ in
               };
             };
           };
+          umami = mkOption {
+            description = "Umami configuration";
+            type = submodule {
+              options = {
+                listenPort = mkOption { type = port; description = "Port to listen to"; };
+                postgresql = mkPsqlOptions "Umami";
+                hashSalt = mkOption { type = str; description = "Hash salt"; };
+              };
+            };
+          };
           yourls = mkOption {
             description = "Yourls configuration";
             type = submodule {