]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Migrate caldance configuration to nixos
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 193e95cf81d8cd64b9e0731af9755b617b033e74..6a2cea0b87c40e4c6fb6e584be7a69df609a2c87 100644 (file)
@@ -1354,6 +1354,21 @@ in
               };
             };
           };
+          caldance = mkOption {
+            description = "Caldance configurations by environment";
+            type = submodule {
+              options = {
+                integration = mkOption {
+                  description = "environment configuration";
+                  type = submodule {
+                    options = {
+                      password = mkOption { type = str; description = "Password file content for basic auth"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           tellesflorian = mkOption {
             description = "Tellesflorian configurations by environment";
             type =