]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Migrate caldance configuration to nixos
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 069a344bc04096de285d2ba6f016b51f0e4e2f39..6a2cea0b87c40e4c6fb6e584be7a69df609a2c87 100644 (file)
@@ -856,6 +856,16 @@ in
       type = submodule {
         options = {
           contact = mkOption { type = str; description = "Contact e-mail address"; };
+          assets = mkOption {
+            default = {};
+            type = attrsOf (submodule {
+              options = {
+                url = mkOption { type = str; description = "URL to fetch"; };
+                sha256 = mkOption { type = str; description = "Hash of the url"; };
+              };
+            });
+            description = "Assets to provide on assets.immae.eu";
+          };
           davical = mkOption {
             description = "Davical configuration";
             type = submodule {
@@ -1344,6 +1354,21 @@ in
               };
             };
           };
+          caldance = mkOption {
+            description = "Caldance configurations by environment";
+            type = submodule {
+              options = {
+                integration = mkOption {
+                  description = "environment configuration";
+                  type = submodule {
+                    options = {
+                      password = mkOption { type = str; description = "Password file content for basic auth"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           tellesflorian = mkOption {
             description = "Tellesflorian configurations by environment";
             type =