]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add relay hosts for specific senders
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 2aa8b5e272c9a9f9924e447cbed7be0594bcaa9a..5f5f6c86c43c3377257bcc0c60043bde60e9e3ff 100644 (file)
@@ -40,14 +40,14 @@ let
       };
     };
   };
-  mkMysqlOptions = name: mkOption {
+  mkMysqlOptions = name: more: mkOption {
     description = "${name} mysql configuration";
     type = submodule {
       options = mysqlOptions // {
         database = mkOption { description = "${name} database"; type = str; };
         user = mkOption { description = "${name} user"; type = str; };
         password = mkOption { description = "mysql password of the ${name} user"; type = str; };
-      };
+      } // more;
     };
   };
   psqlOptions = {
@@ -117,6 +117,11 @@ in
       default = {};
       type = attrsOf (submodule {
         options = {
+          emails = mkOption {
+            default = [];
+            description = "List of e-mails that the server can be a sender of";
+            type = listOf str;
+          };
           ldap = mkOption {
             description = ''
               LDAP credentials for the host
@@ -259,6 +264,7 @@ in
       description = "Jabber configuration";
       type = submodule {
         options = {
+          postfix_user_filter = mkOption { type = str; description = "Postfix filter to get xmpp users"; };
           ldap = mkLdapOptions "Jabber" {};
           postgresql = mkPsqlOptions "Jabber";
         };
@@ -452,7 +458,16 @@ in
         options = {
           status_url = mkOption { type = str; description = "URL to push status to"; };
           status_token = mkOption { type = str; description = "Token for the status url"; };
+          http_user_password = mkOption { type = str; description = "HTTP credentials to check services behind wall"; };
           email = mkOption { type = str; description = "Admin E-mail"; };
+          ssh_public_key = mkOption { type = str; description = "SSH public key"; };
+          ssh_secret_key = mkOption { type = str; description = "SSH secret key"; };
+          imap_login = mkOption { type = str; description = "IMAP login"; };
+          imap_password = mkOption { type = str; description = "IMAP password"; };
+          nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
+          slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
+          slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
+          contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
         };
       };
     };
@@ -518,7 +533,9 @@ in
                   '';
                   type = listOf str;
                 };
-                mysql = mkMysqlOptions "Postfix";
+                mysql = mkMysqlOptions "Postfix" {
+                  password_encrypt = mkOption { type = str; description = "Key to encrypt relay password in database"; };
+                };
                 backup_domains = mkOption {
                   description = ''
                     Domains that are accepted for relay as backup domain
@@ -593,6 +610,7 @@ in
             description = "Mail script recipients";
             type = attrsOf (submodule {
               options = {
+                external = mkEnableOption "Create a script_<name>@mail.immae.eu external address";
                 src = mkOption {
                   description = ''
                     git source to fetch the script from.
@@ -938,7 +956,7 @@ in
             description = "Yourls configuration";
             type = submodule {
               options = {
-                mysql = mkMysqlOptions "Yourls";
+                mysql = mkMysqlOptions "Yourls" {};
                 ldap = mkLdapOptions "Yourls" {};
                 cookieKey = mkOption { type = str; description = "Cookie key"; };
               };
@@ -951,8 +969,8 @@ in
       description = "Websites configurations";
       type = submodule {
         options = {
-          aten = mkOption {
-            description = "Aten configurations by environment";
+          isabelle = mkOption {
+            description = "Isabelle configurations by environment";
             type =
               let
                 atenSubmodule = mkOption {
@@ -968,8 +986,8 @@ in
               in
                 submodule {
                   options = {
-                    production = atenSubmodule;
-                    integration = atenSubmodule;
+                    aten_production = atenSubmodule;
+                    aten_integration = atenSubmodule;
                   };
                 };
           };
@@ -982,7 +1000,7 @@ in
                   type = submodule {
                     options = {
                       environment = mkOption { type = str; description = "Symfony environment"; };
-                      mysql = mkMysqlOptions "Chloe";
+                      mysql = mkMysqlOptions "Chloe" {};
                       ldap = mkLdapOptions "Chloe" {};
                     };
                   };
@@ -1004,7 +1022,7 @@ in
                   type = submodule {
                     options = {
                       environment = mkOption { type = str; description = "Symfony environment"; };
-                      mysql = mkMysqlOptions "Connexionswing";
+                      mysql = mkMysqlOptions "Connexionswing" {};
                       secret = mkOption { type = str; description = "Symfony App secret"; };
                       email = mkOption { type = str; description = "Symfony email notification"; };
                     };
@@ -1022,7 +1040,7 @@ in
             description = "Naturaloutil configuration";
             type = submodule {
               options = {
-                mysql = mkMysqlOptions "Naturaloutil";
+                mysql = mkMysqlOptions "Naturaloutil" {};
                 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
               };
             };
@@ -1044,7 +1062,7 @@ in
                   type = submodule {
                     options = {
                       environment = mkOption { type = str; description = "Symfony environment"; };
-                      mysql = mkMysqlOptions "LudivineCassal";
+                      mysql = mkMysqlOptions "LudivineCassal" {};
                       ldap = mkLdapOptions "LudivineCassal" {};
                       secret = mkOption { type = str; description = "Symfony App secret"; };
                     };
@@ -1091,7 +1109,7 @@ in
                   type = submodule {
                     options = {
                       environment = mkOption { type = str; description = "Symfony environment"; };
-                      mysql = mkMysqlOptions "Piedsjaloux";
+                      mysql = mkMysqlOptions "Piedsjaloux" {};
                       secret = mkOption { type = str; description = "Symfony App secret"; };
                     };
                   };
@@ -1104,6 +1122,23 @@ in
                   };
                 };
           };
+          richie = mkOption {
+            description = "Europe Richie configurations by environment";
+            type = submodule {
+              options = {
+                mysql = mkMysqlOptions "Richie" {};
+                smtp_mailer = mkOption {
+                  description = "SMTP mailer configuration";
+                  type = submodule {
+                    options = {
+                      user = mkOption { type = str; description = "Username"; };
+                      password = mkOption { type = str; description = "Password"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           tellesflorian = mkOption {
             description = "Tellesflorian configurations by environment";
             type =
@@ -1113,7 +1148,7 @@ in
                   type = submodule {
                     options = {
                       environment = mkOption { type = str; description = "Symfony environment"; };
-                      mysql = mkMysqlOptions "Tellesflorian";
+                      mysql = mkMysqlOptions "Tellesflorian" {};
                       secret = mkOption { type = str; description = "Symfony App secret"; };
                       invite_passwords = mkOption { type = str; description = "Password basic auth"; };
                     };