]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add monitoring host
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 9bfb80a7609a7c2926e3894ef6311385150f1298..550b06018d13e6f8a31edf159d9db53f36159c0b 100644 (file)
@@ -117,6 +117,11 @@ in
       default = {};
       type = attrsOf (submodule {
         options = {
+          emails = mkOption {
+            default = [];
+            description = "List of e-mails that the server can be a sender of";
+            type = listOf str;
+          };
           ldap = mkOption {
             description = ''
               LDAP credentials for the host
@@ -453,7 +458,16 @@ in
         options = {
           status_url = mkOption { type = str; description = "URL to push status to"; };
           status_token = mkOption { type = str; description = "Token for the status url"; };
+          http_user_password = mkOption { type = str; description = "HTTP credentials to check services behind wall"; };
           email = mkOption { type = str; description = "Admin E-mail"; };
+          ssh_public_key = mkOption { type = str; description = "SSH public key"; };
+          ssh_secret_key = mkOption { type = str; description = "SSH secret key"; };
+          imap_login = mkOption { type = str; description = "IMAP login"; };
+          imap_password = mkOption { type = str; description = "IMAP password"; };
+          nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
+          slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
+          slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
+          contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
         };
       };
     };