]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add dilion server
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index c4c32c8e34a32d6392ac920eb8e80f10baa0fb1d..3b51f37a7458f49513c7cf32259ef688f6364fa1 100644 (file)
@@ -114,6 +114,14 @@ let
         description = "Host FQDN";
         type = str;
       };
+      users = mkOption {
+        type = unspecified;
+        default = pkgs: [];
+        description = ''
+          Sublist of users from realUsers. Function that takes pkgs as
+          argument and gives an array as a result
+        '';
+      };
       emails = mkOption {
         default = [];
         description = "List of e-mails that the server can be a sender of";
@@ -287,6 +295,14 @@ in
         };
       };
     };
+    realUsers = mkOption {
+      description = ''
+        Attrset of function taking pkgs as argument.
+        Real users settings, should provide a subattr of users.users.<name>
+        with at least: name, (hashed)Password, shell
+      '';
+      type = attrsOf unspecified;
+    };
     users = mkOption {
       description = "System and regular users uid/gid";
       type = attrsOf (submodule {