]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add keys handling for bind9
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 490a4051bf3604b5bd4591d7562ed0395e5e743b..32af33989b6d5af31d53029485c9b73da4ceda06 100644 (file)
@@ -384,6 +384,16 @@ in
             };
             type = attrsOf (attrsOf (listOf str));
           };
+          keys = mkOption {
+            default = {};
+            description = "DNS keys";
+            type = attrsOf (submodule {
+              options = {
+                algorithm = mkOption { type = str; description = "Algorithm"; };
+                secret    = mkOption { type = str; description = "Secret"; };
+              };
+            });
+          };
           slaveZones = mkOption {
             description = "List of slave zones";
             type = listOf (submodule {
@@ -393,6 +403,11 @@ in
                   description = "NS master groups of this zone";
                   type = listOf str;
                 };
+                keys = mkOption {
+                  default = [];
+                  description = "Keys associated to the server";
+                  type = listOf str;
+                };
               };
             });
           };
@@ -401,6 +416,7 @@ in
             type = listOf (submodule {
               options = {
                 name = mkOption { type = str; description = "zone name"; };
+                withCAA = mkOption { type = nullOr str; description = "CAA entry"; default = null; };
                 slaves = mkOption {
                   description = "NS slave groups of this zone";
                   type = listOf str;
@@ -562,6 +578,7 @@ in
             description = "Eban credentials for webhook";
             type = submodule {
               options = {
+                user = mkOption { type = str; description = "User"; };
                 password = mkOption { type = str; description = "Password"; };
               };
             };