]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add syden peertube website
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 50f153ac141616df1ef7959a9eb1c0e920122274..29ea1739f962bf9c65c57b17df241b982ea81aab 100644 (file)
@@ -114,6 +114,14 @@ let
         description = "Host FQDN";
         type = str;
       };
+      users = mkOption {
+        type = unspecified;
+        default = pkgs: [];
+        description = ''
+          Sublist of users from realUsers. Function that takes pkgs as
+          argument and gives an array as a result
+        '';
+      };
       emails = mkOption {
         default = [];
         description = "List of e-mails that the server can be a sender of";
@@ -125,8 +133,8 @@ let
         '';
         type = submodule {
           options = {
-            password = mkOption { type = string; description = "Password for the LDAP connection"; };
-            dn = mkOption { type = string; description = "DN for the LDAP connection"; };
+            password = mkOption { type = str; description = "Password for the LDAP connection"; };
+            dn = mkOption { type = str; description = "DN for the LDAP connection"; };
           };
         };
       };
@@ -148,13 +156,13 @@ let
         type = attrsOf (submodule {
           options = {
             ip4 = mkOption {
-              type = string;
+              type = str;
               description = ''
                 ip4 address of the host
               '';
             };
             ip6 = mkOption {
-              type = listOf string;
+              type = listOf str;
               default = [];
               description = ''
                 ip6 addresses of the host
@@ -287,6 +295,14 @@ in
         };
       };
     };
+    realUsers = mkOption {
+      description = ''
+        Attrset of function taking pkgs as argument.
+        Real users settings, should provide a subattr of users.users.<name>
+        with at least: name, (hashed)Password, shell
+      '';
+      type = attrsOf unspecified;
+    };
     users = mkOption {
       description = "System and regular users uid/gid";
       type = attrsOf (submodule {
@@ -420,7 +436,6 @@ in
         '';
       type = submodule {
         options = {
-          mailto = mkOption { type = str; description = "Where to e-mail on error"; };
           ssh_key = mkOption {
             description = "SSH key information";
             type = submodule {
@@ -481,10 +496,36 @@ in
           ssh_secret_key = mkOption { type = str; description = "SSH secret key"; };
           imap_login = mkOption { type = str; description = "IMAP login"; };
           imap_password = mkOption { type = str; description = "IMAP password"; };
+          eriomem_keys = mkOption { type = listOf (listOf str); description = "Eriomem keys"; default = []; };
+          ovh_sms = mkOption {
+            description = "OVH credentials for sms script";
+            type = submodule {
+              options = {
+                endpoint = mkOption { type = str; default = "ovh-eu"; description = "OVH endpoint"; };
+                application_key = mkOption { type = str; description = "Application key"; };
+                application_secret = mkOption { type = str; description = "Application secret"; };
+                consumer_key = mkOption { type = str; description = "Consumer key"; };
+                account = mkOption { type = str; description = "Account"; };
+              };
+            };
+          };
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
           slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
           slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
           contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
+          email_check = mkOption {
+            description = "Emails services to check";
+            type = attrsOf (submodule {
+              options = {
+                local = mkOption { type = bool; default = false; description = "Use local configuration"; };
+                port = mkOption { type = nullOr str; default = null; description = "Port to connect to ssh"; };
+                login = mkOption { type = nullOr str; default = null; description = "Login to connect to ssh"; };
+                targets = mkOption { type = listOf str; description = "Hosts to send E-mails to"; };
+                mail_address = mkOption { type = nullOr str; default = null; description = "E-mail recipient part to send e-mail to"; };
+                mail_domain = mkOption { type = nullOr str; default = null; description = "E-mail domain part to send e-mail to"; };
+              };
+            });
+          };
         };
       };
     };
@@ -507,6 +548,16 @@ in
         };
       };
     };
+    vpn = mkOption {
+      description = "VPN configuration";
+      type = attrsOf (submodule {
+        options = {
+          prefix = mkOption { type = str; description = "ipv6 prefix for the vpn subnet"; };
+          privateKey = mkOption { type = str; description = "Private key for the host"; };
+          publicKey = mkOption { type = str; description = "Public key for the host"; };
+        };
+      });
+    };
     mail = mkOption {
       description = "Mail configuration";
       type = submodule {
@@ -866,6 +917,16 @@ in
               };
             };
           };
+          syden_peertube = mkOption {
+            description = "Peertube Syden configuration";
+            type = submodule {
+              options = {
+                listenPort = mkOption { type = port; description = "Port to listen to"; };
+                postgresql = mkPsqlOptions "Peertube";
+                redis = mkRedisOptions "Peertube";
+              };
+            };
+          };
           phpldapadmin = mkOption {
             description = "phpLdapAdmin configuration";
             type = submodule {