]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Use zrepl to make zfs backups
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 6a2cea0b87c40e4c6fb6e584be7a69df609a2c87..0f6f3e2d50854f3f260c36afaca52a8b19d16db8 100644 (file)
@@ -462,6 +462,22 @@ in
         };
       };
     };
+    zrepl_backup = mkOption {
+      type = submodule {
+        options = {
+          ssh_key = mkOption {
+            description = "SSH key information";
+            type = submodule {
+              options = {
+                public = mkOption { type = str; description = "Public part of the key"; };
+                private = mkOption { type = lines; description = "Private part of the key"; };
+              };
+            };
+          };
+          mysql = mkMysqlOptions "Zrepl" {};
+        };
+      };
+    };
     rsync_backup = mkOption {
       description  =''
         Rsync backup configuration from controlled host