]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Refactor websites
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 77e9c8d6d9725a6866833e01abed14da276b4df7..01ab967bf53551d8cd7eae627c98dd6a1ca4e158 100644 (file)
@@ -917,6 +917,16 @@ in
               };
             };
           };
+          syden_peertube = mkOption {
+            description = "Peertube Syden configuration";
+            type = submodule {
+              options = {
+                listenPort = mkOption { type = port; description = "Port to listen to"; };
+                postgresql = mkPsqlOptions "Peertube";
+                redis = mkRedisOptions "Peertube";
+              };
+            };
+          };
           phpldapadmin = mkOption {
             description = "phpLdapAdmin configuration";
             type = submodule {
@@ -1123,7 +1133,7 @@ in
               };
             };
           };
-          telioTortay = mkOption {
+          telio_tortay = mkOption {
             description = "Telio Tortay configuration";
             type = submodule {
               options = {
@@ -1131,7 +1141,7 @@ in
               };
             };
           };
-          ludivinecassal = mkOption {
+          ludivine = mkOption {
             description = "Ludivinecassal configurations by environment";
             type =
               let