]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/dns.nix
Add keys handling for bind9
[perso/Immae/Config/Nix.git] / modules / private / dns.nix
index cb900ffad6ca725b9853666d6055c095117b716f..1149daf6787508f36befea23903b7360774f80e6 100644 (file)
@@ -3,6 +3,15 @@
   options.myServices.dns.enable = lib.mkEnableOption "enable DNS resolver";
   config = let
     cfg = config.services.bind;
+    keyIncludes = builtins.concatStringsSep "\n" (map (v: "include \"/var/secrets/bind/${v}.key\";") (builtins.attrNames config.myEnv.dns.keys));
+    toKeyList = servers: keys: builtins.concatStringsSep "\n" (map (s: ''
+      server ${s} {
+        keys { ${builtins.concatStringsSep ";" keys}; };
+      };
+    '') servers);
+    serverIncludes = builtins.concatStringsSep "\n" (map (v:
+      lib.optionalString (builtins.length v.keys > 0) (toKeyList (lib.flatten (map (n: builtins.attrValues config.myEnv.dns.ns."${n}") v.masters)) v.keys)
+    ) config.myEnv.dns.slaveZones);
     configFile = pkgs.writeText "named.conf" ''
       include "/etc/bind/rndc.key";
       controls {
@@ -24,6 +33,9 @@
         ${cfg.extraOptions}
       };
 
+      ${keyIncludes}
+      ${serverIncludes}
+
       ${cfg.extraConfig}
 
       ${ lib.concatMapStrings
   in lib.mkIf config.myServices.dns.enable {
     networking.firewall.allowedUDPPorts = [ 53 ];
     networking.firewall.allowedTCPPorts = [ 53 ];
+    users.users.named.extraGroups = [ "keys" ];
+    secrets.keys = lib.mapAttrsToList (k: v:
+      {
+        dest = "bind/${k}.key";
+        permissions = "0400";
+        user = "named";
+        text = ''
+          key "${k}"
+            {
+              algorithm ${v.algorithm};
+              secret "${v.secret}";
+            };
+        '';
+      }
+    ) config.myEnv.dns.keys;
     services.bind = {
       enable = true;
       cacheNetworks = ["any"];