]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/databases/redis.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / databases / redis.nix
index 693f40261627d7b1cdba473446de86257c823525..4b26283ee1b928887653445b74c8721775c34ff5 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, config, pkgs, myconfig, ... }:
+{ lib, config, pkgs, ... }:
 let
     cfg = config.myServices.databases.redis;
 in {
@@ -96,7 +96,7 @@ in {
           WorkerThreads 1
 
           Authority {
-              Auth "${myconfig.env.databases.redis.predixy.read}" {
+              Auth "${config.myEnv.databases.redis.predixy.read}" {
                   Mode read
               }
           }
@@ -105,7 +105,7 @@ in {
             Databases 16
             RefreshMethod fixed
             Group shard001 {
-              + ${myconfig.env.databases.redis.socket}
+              + ${config.myEnv.databases.redis.socket}
             }
           }
           '';
@@ -115,7 +115,7 @@ in {
         user = "spiped";
         group = "spiped";
         permissions = "0400";
-        text = myconfig.env.databases.redis.spiped_key;
+        text = config.myEnv.databases.redis.spiped_key;
       }
     ];