]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/databases/postgresql.nix
Upgrade to nixos-unstable
[perso/Immae/Config/Nix.git] / modules / private / databases / postgresql.nix
index d0b1a7569b8276d7aa8d3ba5b1c225905d2d03a9..c442a63c01b727913b41f5e275c130fd918497db 100644 (file)
@@ -100,7 +100,6 @@ in {
     security.acme.certs."postgresql" = config.myServices.databasesCerts // {
       user = "postgres";
       group = "postgres";
-      plugins = [ "fullchain.pem" "key.pem" "account_key.json" "account_reg.json" ];
       domain = "db-1.immae.eu";
       postRun = ''
         systemctl reload postgresql.service
@@ -212,22 +211,20 @@ in {
 
     security.pam.services = let
       pam_ldap = "${pkgs.pam_ldap}/lib/security/pam_ldap.so";
-    in [
-      {
-        name = "postgresql";
+    in {
+      postgresql = {
         text = ''
           auth    required ${pam_ldap} config=${config.secrets.location}/postgresql/pam
           account required ${pam_ldap} config=${config.secrets.location}/postgresql/pam
           '';
-      }
-      {
-        name = "postgresql_replication";
+      };
+      postgresql_replication = {
         text = ''
           auth    required ${pam_ldap} config=${config.secrets.location}/postgresql/pam_replication
           account required ${pam_ldap} config=${config.secrets.location}/postgresql/pam_replication
           '';
-      }
-    ];
+      };
+    };
   };
 }